summaryrefslogtreecommitdiff
path: root/dev-python/clint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/clint
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/clint')
-rw-r--r--dev-python/clint/Manifest3
-rw-r--r--dev-python/clint/clint-0.5.1.ebuild41
-rw-r--r--dev-python/clint/metadata.xml7
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/clint/Manifest b/dev-python/clint/Manifest
new file mode 100644
index 000000000000..64c2a34e9d9e
--- /dev/null
+++ b/dev-python/clint/Manifest
@@ -0,0 +1,3 @@
+DIST clint-0.5.1.tar.gz 81140 BLAKE2B 5b42e7d46321f0416d3ffb51edf66c53476d3e4a211e971f36cab54a412f6b0f0ec26486c2b95871956ab09e7e4adf68e8329dd7e9e3c7ed1adb3f8a0dd2a728 SHA512 3ad8bfc587acb1322c7d7c3e73756a07c98f3b4215a3d4dc409b5a2067bc70dce2dd98d19250b8122b319b7bcf5e2859251de2829780345de06f93b35447c4e8
+EBUILD clint-0.5.1.ebuild 953 BLAKE2B 0ef52583a238e73f5026a6feb21918830597ddfc1c7593d15667a742219679f28b8bc09ed34f64d7629c4402dc33820fa449aab6b0b50a43b659393883d3d48a SHA512 ba012d77cc1fceebf281c0d641da81f17b2678c7fc1aab6e0a804298f3fdfa9e65d0a87a2dd181c3d1b03d32206506bbbae9b4f7e2d2a79b5e86bbc749232d90
+MISC metadata.xml 222 BLAKE2B e38fd6b3adcc5736d84eccc152fae308171324da8a845eacd6b5e5d0b4d18cf1ccc5436bb66f26dc3eb0cf5e4eb03549f52b23a51403d8677713c2295f773f0b SHA512 714a5bebab34700e6110a052f7b6a094ca2532c6b860d7a707e645c75da1c2c7710aab5f9e9fdd4a5c189a92c115dc27e9fec70baaaa3769550c4a0218aa1c94
diff --git a/dev-python/clint/clint-0.5.1.ebuild b/dev-python/clint/clint-0.5.1.ebuild
new file mode 100644
index 000000000000..9140d667e9f7
--- /dev/null
+++ b/dev-python/clint/clint-0.5.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python Command-line Application Tools"
+HOMEPAGE="https://github.com/kennethreitz/clint"
+SRC_URI="https://github.com/kennethreitz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE="doc examples test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND="dev-python/args[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/clint/metadata.xml b/dev-python/clint/metadata.xml
new file mode 100644
index 000000000000..1e32239530f0
--- /dev/null
+++ b/dev-python/clint/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="github">kennethreitz/clint</remote-id>
+ </upstream>
+</pkgmetadata>