summaryrefslogtreecommitdiff
path: root/dev-python/clikit/clikit-0.6.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-19 14:36:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-19 14:36:42 +0100
commitb1f2cdf56e5eea363adc4c1ea1bd418f65733a7a (patch)
treeef4ac59664753af1fc4d1e8c2cb41114483230a6 /dev-python/clikit/clikit-0.6.2-r1.ebuild
parent19a10140592052698d68be11db5a59bc88fcf528 (diff)
gentoo auto-resync : 19:08:2022 - 14:36:41
Diffstat (limited to 'dev-python/clikit/clikit-0.6.2-r1.ebuild')
-rw-r--r--dev-python/clikit/clikit-0.6.2-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/clikit/clikit-0.6.2-r1.ebuild b/dev-python/clikit/clikit-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..3b1b46b4b24b
--- /dev/null
+++ b/dev-python/clikit/clikit-0.6.2-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Group of utilities to build beautiful and testable command line interfaces"
+HOMEPAGE="
+ https://github.com/sdispater/clikit/
+ https://pypi.org/project/clikit/
+"
+SRC_URI="
+ https://github.com/sdispater/clikit/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/pastel[${PYTHON_USEDEP}]
+ dev-python/pylev[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/crashtest[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_mock.plugin
+ local -x COLUMNS=80
+ epytest
+}