summaryrefslogtreecommitdiff
path: root/dev-python/cliff
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /dev-python/cliff
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'dev-python/cliff')
-rw-r--r--dev-python/cliff/Manifest2
-rw-r--r--dev-python/cliff/cliff-2.11.0.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/cliff/Manifest b/dev-python/cliff/Manifest
index 5b3ca6c0788f..ba8fe829025e 100644
--- a/dev-python/cliff/Manifest
+++ b/dev-python/cliff/Manifest
@@ -1,3 +1,5 @@
+DIST cliff-2.11.0.tar.gz 77037 BLAKE2B a38f37574f1802a2724143f35cc1d1159d8165f75f4c9e582e726cfdc9090814635d99b073a5d8df3a3e3b3d57b79e4e383c0569bd6769325d81af69384e9946 SHA512 0f29431b30610f0c781c9eddac57724043b6d7c05bc82f0ec3027a68230222f18f78ffc1d82dbd8ff4b5408b255b27879bbc1266e8641b4bc1c871f029f6cba2
DIST cliff-2.8.0.tar.gz 71815 BLAKE2B d73d467a1e2e06e5f45e7fce766d6c8daf79d9a882692c0e77049427bb6de629409a282c8c554ba92c62a9c8fd44e0b19cd3cd93b9b3f1f2b8091a1e917a25b8 SHA512 a371916945ee71ec519aeb923ca44b0a0e10fe6e460d236434c5c2946ad2b517050bf9d0430bdde506bdf2d28ba60bd45941d9ce21d77a83e2d5541b088d04b3
+EBUILD cliff-2.11.0.ebuild 1794 BLAKE2B 4762b3ec99c3f8b1faf511f24911a5d2235f5c3a7145dccd170cdf0b8e6552bb88e4f14c5c6e6ee240e2df6f9ced4cddf1e6e4438f9d166eecb301d03aff3f64 SHA512 96f5671663c1081839d0495b7df119bbea640afb5562cb6c21188c927d9f972b0c5174a44a826dbff0865bb51770fafccb5b8884a4a3cbd2f058cb1b090fcb78
EBUILD cliff-2.8.0.ebuild 1803 BLAKE2B 1c356b186cd61f0b64ec018b9b798832541d967bc78335e6ac8c1bb80b20656bcc7d05c4c6bc62d4262ecd2efce17e1ca0db2329fd748919b78d33ad72edeb86 SHA512 714dcf939b7044a111e7e40fd8efa141907ea852d4f763ebc4b39fd4bb792445d078f85132ede9171d237af386025c5743236fdb0d19daa3a59a70a17fc15001
MISC metadata.xml 709 BLAKE2B 05e69832a5cff97a52caebc4c113a39342e62803fd523a753a8ba119f4326a9814c7c382e88906514e539922c1f22683a09dd46b2c11e3d60b8f885072a08e72 SHA512 f031fa34d06b4c12c8eba5a046c07f1e391fd84bd29d6a4ca8c769c2d774262d66d7bac12d05cb8ef669db7e2713d6862b6a118e9f9ca810e9ae0fa9fb881892
diff --git a/dev-python/cliff/cliff-2.11.0.ebuild b/dev-python/cliff/cliff-2.11.0.ebuild
new file mode 100644
index 000000000000..0d69f56ea359
--- /dev/null
+++ b/dev-python/cliff/cliff-2.11.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="https://github.com/dreamhost/cliff"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ )
+"
+# source files stipulate <sphinx-1.3 however build effected perfectly with sphinx-1.3.1
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/cmd2-0.6.7[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/unicodecsv-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
+ "
+
+python_compile() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ nosetests ${PN}/tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}