summaryrefslogtreecommitdiff
path: root/dev-python/cliff
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-14 07:56:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-14 07:56:51 +0000
commit2e4747a36a51fd58c21f3f00db959709e83fe08b (patch)
tree55b3fa7393c53b4b2fa2bb96fdae27d9d4444a97 /dev-python/cliff
parent5c1e419582680cfb61e0ae777c693704f3a731e1 (diff)
gentoo auto-resync : 14:02:2023 - 07:56:50
Diffstat (limited to 'dev-python/cliff')
-rw-r--r--dev-python/cliff/Manifest2
-rw-r--r--dev-python/cliff/cliff-4.2.0.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/cliff/Manifest b/dev-python/cliff/Manifest
index b55b2cc29375..d5903e24d332 100644
--- a/dev-python/cliff/Manifest
+++ b/dev-python/cliff/Manifest
@@ -1,3 +1,5 @@
DIST cliff-4.1.0.tar.gz 82892 BLAKE2B 2d4da66ca6ba86c9f0f33fa36f637363a25ac0ea5c7a1561a4e682769e7ecc97525fca93fde0597062e8f23c4d3334fbf08a305f1c5bb15918e5752a45992d0e SHA512 4bab3404207d21cf8111a6dc1a0ece2c8da5d3bf5ee261b351b7b7ade73f162c4cea225be6fac7444ae95de70d3079e727086fd954fbf56b6d61fb1c7eb4c44a
+DIST cliff-4.2.0.tar.gz 83168 BLAKE2B ac2d288ac3728f4266d61edb9b6aedc897e9020d3f8a74ebba4721530942a27335564c2a95406a4d6b5374df49e38bc0aa303d3aff12f83c91e48c59f13aa45f SHA512 6f0c31b49603be5289e6d4c9b2572862e977264df21dc14d976289c627909102d672ee8ffa5b6cd79b3a349158ff8f36444a2d2061e18eeb7121ce79b2d5719b
EBUILD cliff-4.1.0.ebuild 1167 BLAKE2B 9fb84a122ef09d0a3a1dd1d6636f26903a2345bd28b9539d82b42b1cf4a2ef16d067d7a0fceb113c2a8d61ac6077d1cba0c41caed0c4d8dc8a0f2e330cd3dd5f SHA512 1cf59fdccfc59c6b1d50dd925bc3459362525c7c404ea9ade959111d86a12f5cdb59f123d3c5d91c11ca8fa0031201df247d421b79870c826987010286286189
+EBUILD cliff-4.2.0.ebuild 1124 BLAKE2B aea92338757e1f61a224e791a77f9ae73bac17aed56452606e1f741620e99eb36e4cb0cc8df0d363860ebc0b979f7db89bad0e318d267b51ed58752bbb576b4b SHA512 ca4339e5d0bd02960f43ceba9e01cdeb7a49896fe4f9f2b90feafac174e908df5ce3eeeed891893e2f1eb40feb8ab430c59870c176ab3a3795ba92abfa4c564d
MISC metadata.xml 767 BLAKE2B d9d994960046172167f20f59073011b2defe84e94144386db5465a973050e48e05abccff88d7f84cbe9f20615eddc5b61a46920f8b27c4dc9b2587f762f3e368 SHA512 018a0bfac3f0126341207d16203fab4a666b17d8a5dcf9f101335c396797f2e724e2250910fca39e12cb6616614983a756a42dac03aa215d2a1b51af5246269b
diff --git a/dev-python/cliff/cliff-4.2.0.ebuild b/dev-python/cliff/cliff-4.2.0.ebuild
new file mode 100644
index 000000000000..d6f9228178d6
--- /dev/null
+++ b/dev-python/cliff/cliff-4.2.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="
+ https://opendev.org/openstack/cliff/
+ https://github.com/openstack/cliff/
+ https://pypi.org/project/cliff/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/autopage-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.11.1[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest