summaryrefslogtreecommitdiff
path: root/dev-python/click-help-colors/click-help-colors-0.9.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-18 17:04:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-18 17:04:41 +0000
commit6cdde4bf2702fac82ba7163fe9f922e7fa0b9a66 (patch)
tree876fe918d1abfd24cf9323208d2929b94a47cfc7 /dev-python/click-help-colors/click-help-colors-0.9.4.ebuild
parentce89e807ecd2194613ad6e6bcee8cf95e982ad1a (diff)
gentoo auto-resync : 18:11:2023 - 17:04:41
Diffstat (limited to 'dev-python/click-help-colors/click-help-colors-0.9.4.ebuild')
-rw-r--r--dev-python/click-help-colors/click-help-colors-0.9.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/click-help-colors/click-help-colors-0.9.4.ebuild b/dev-python/click-help-colors/click-help-colors-0.9.4.ebuild
new file mode 100644
index 000000000000..1f2d4a2665be
--- /dev/null
+++ b/dev-python/click-help-colors/click-help-colors-0.9.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Colorization of help messages in Click"
+HOMEPAGE="
+ https://github.com/click-contrib/click-help-colors/
+ https://pypi.org/project/click-help-colors/
+"
+SRC_URI="
+ https://github.com/click-contrib/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}