summaryrefslogtreecommitdiff
path: root/dev-python/click-help-colors/click-help-colors-0.9.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
commit514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (patch)
tree555c194dbeb0fb2ac4ad3cde7c0f6a80fd330ce2 /dev-python/click-help-colors/click-help-colors-0.9.1.ebuild
parent4df3bf9762850b34cd1ead5c80374d1a0fc3362e (diff)
gentoo resync : 17.07.2021
Diffstat (limited to 'dev-python/click-help-colors/click-help-colors-0.9.1.ebuild')
-rw-r--r--dev-python/click-help-colors/click-help-colors-0.9.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/click-help-colors/click-help-colors-0.9.1.ebuild b/dev-python/click-help-colors/click-help-colors-0.9.1.ebuild
new file mode 100644
index 000000000000..251b5c3328a4
--- /dev/null
+++ b/dev-python/click-help-colors/click-help-colors-0.9.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Colorization of help messages in Click"
+HOMEPAGE="https://github.com/click-contrib/click-help-colors"
+SRC_URI="
+ https://github.com/click-contrib/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND="dev-python/click[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}