summaryrefslogtreecommitdiff
path: root/dev-python/click-help-colors/click-help-colors-0.9.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-21 01:03:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-21 01:03:25 +0000
commitd32022e7301aef2b3f52f6b7a3de81c6e03ffcaf (patch)
tree4e64fbab713348c061644255d893ff91f2d8b1e5 /dev-python/click-help-colors/click-help-colors-0.9.1-r1.ebuild
parent92f98ae772a60a2fa63efbda2f915da957a3b3b8 (diff)
gentoo auto-resync : 21:11:2022 - 01:03:25
Diffstat (limited to 'dev-python/click-help-colors/click-help-colors-0.9.1-r1.ebuild')
-rw-r--r--dev-python/click-help-colors/click-help-colors-0.9.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/click-help-colors/click-help-colors-0.9.1-r1.ebuild b/dev-python/click-help-colors/click-help-colors-0.9.1-r1.ebuild
new file mode 100644
index 000000000000..485d4219691e
--- /dev/null
+++ b/dev-python/click-help-colors/click-help-colors-0.9.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Colorization of help messages in Click"
+HOMEPAGE="https://github.com/click-contrib/click-help-colors"
+SRC_URI="
+ https://github.com/click-contrib/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="examples"
+
+RDEPEND="dev-python/click[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}