summaryrefslogtreecommitdiff
path: root/dev-python/cli_helpers/cli_helpers-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
commit51af5f0eb4cddbe6aa7953717873691d77aae9ff (patch)
tree1541525274162b033ebbc3ed38abaf335fbbd49a /dev-python/cli_helpers/cli_helpers-9999.ebuild
parent7014a5a3ea0feffab9701fdd6b64cc7667a985af (diff)
gentoo resync : 11.07.2019
Diffstat (limited to 'dev-python/cli_helpers/cli_helpers-9999.ebuild')
-rw-r--r--dev-python/cli_helpers/cli_helpers-9999.ebuild26
1 files changed, 20 insertions, 6 deletions
diff --git a/dev-python/cli_helpers/cli_helpers-9999.ebuild b/dev-python/cli_helpers/cli_helpers-9999.ebuild
index a781b76eb170..edaf342667d6 100644
--- a/dev-python/cli_helpers/cli_helpers-9999.ebuild
+++ b/dev-python/cli_helpers/cli_helpers-9999.ebuild
@@ -1,24 +1,38 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
EGIT_REPO_URI="https://github.com/dbcli/${PN}.git"
inherit distutils-r1 git-r3
DESCRIPTION="Python helpers for common CLI tasks"
-
HOMEPAGE="http://cli-helpers.rtfd.io/"
SRC_URI=""
+
LICENSE="BSD"
SLOT="0"
KEYWORDS=""
IUSE=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
RDEPEND="
- >=dev-python/backports-csv-1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/backports-csv-1.0[${PYTHON_USEDEP}]' -2)
+ >=dev-python/configobj-5.0.5[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
>=dev-python/tabulate-0.8.0[${PYTHON_USEDEP}]
>=dev-python/terminaltables-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/mock-2[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}