summaryrefslogtreecommitdiff
path: root/dev-python/cli_helpers/cli_helpers-2.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-13 19:42:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-13 19:42:47 +0100
commit174cda0f83caffc0ee683143e9b2c501ef589cc1 (patch)
treee60c3821d3cb0c6c19deaf8ad9c846f57791f3bf /dev-python/cli_helpers/cli_helpers-2.3.0.ebuild
parent22b51dcc430fb550fd692463a56cdcd5b18efd61 (diff)
gentoo auto-resync : 13:10:2022 - 19:42:47
Diffstat (limited to 'dev-python/cli_helpers/cli_helpers-2.3.0.ebuild')
-rw-r--r--dev-python/cli_helpers/cli_helpers-2.3.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/cli_helpers/cli_helpers-2.3.0.ebuild b/dev-python/cli_helpers/cli_helpers-2.3.0.ebuild
new file mode 100644
index 000000000000..f9592c921866
--- /dev/null
+++ b/dev-python/cli_helpers/cli_helpers-2.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python helpers for common CLI tasks"
+HOMEPAGE="
+ https://cli-helpers.rtfd.io/
+ https://github.com/dbcli/cli_helpers/
+ https://pypi.org/project/cli-helpers/
+"
+SRC_URI="
+ https://github.com/dbcli/cli_helpers/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/configobj-5.0.5[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest