summaryrefslogtreecommitdiff
path: root/dev-python/cleo/cleo-2.0.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-06 15:39:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-06 15:39:49 +0100
commita52a3a626c1d57fc0b3dbf58e79a23e88c3dd4ff (patch)
tree82d493ce372e412edd2cd56af2108b00677d5f74 /dev-python/cleo/cleo-2.0.1-r1.ebuild
parent996d1cba721b044876526a7f3c1d2ef1fcc90bb4 (diff)
gentoo auto-resync : 06:06:2023 - 15:39:49
Diffstat (limited to 'dev-python/cleo/cleo-2.0.1-r1.ebuild')
-rw-r--r--dev-python/cleo/cleo-2.0.1-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/cleo/cleo-2.0.1-r1.ebuild b/dev-python/cleo/cleo-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..59262d78b9eb
--- /dev/null
+++ b/dev-python/cleo/cleo-2.0.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python tool for building testable command-line interfaces"
+HOMEPAGE="
+ https://github.com/python-poetry/cleo/
+ https://pypi.org/project/cleo/
+"
+SRC_URI="
+ https://github.com/python-poetry/cleo/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/crashtest[${PYTHON_USEDEP}]
+ dev-python/rapidfuzz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin rapidfuzz
+ sed -i -e '/rapidfuzz/s:\^:>=:' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_mock
+ epytest
+}