summaryrefslogtreecommitdiff
path: root/dev-python/clang-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-25 14:07:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-25 14:07:44 +0000
commit6a84e414622fd99c22318ce656a77bb2a0433fc7 (patch)
tree048f41d4a2a9c373e50bf0906c5508e6f5104fae /dev-python/clang-python
parenta1b20429e7e2ba1b44414459afd5a2b50788cd9c (diff)
gentoo auto-resync : 25:01:2023 - 14:07:44
Diffstat (limited to 'dev-python/clang-python')
-rw-r--r--dev-python/clang-python/Manifest1
-rw-r--r--dev-python/clang-python/clang-python-17.0.0.9999.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/clang-python/Manifest b/dev-python/clang-python/Manifest
index 397198b19961..2b33f8337458 100644
--- a/dev-python/clang-python/Manifest
+++ b/dev-python/clang-python/Manifest
@@ -12,4 +12,5 @@ EBUILD clang-python-15.0.6.ebuild 1202 BLAKE2B b655ab7b2fa3a5334666e42d36e1e7773
EBUILD clang-python-15.0.7.ebuild 1204 BLAKE2B 7147fb79338449b0a955f7f5010e8fdba34848f9fb84b9df9ceefbcc9c1829def49d7157054ef2f707225d2bff673b67d37b82b2fb373b75355583a205db6b50 SHA512 e99332305557a698a231391bad9ba6c1677c7cf13ab64d9c79e6900029f373face1b89acc55321305b12ab6cd70b946609d6352318467c0c11ea1c5d2efff425
EBUILD clang-python-16.0.0.9999.ebuild 1181 BLAKE2B 2628ec06a37f501d0fbe285ec294050a999816997028b0813cd68cabab97139abb229688fcdd9d496a4c045fb55907ffbe9f9861ec5cc34d41bba64f8affee89 SHA512 4df861292429fe4bdce21f387db7051172950ece21607fda3a2b11504ae93f7b301a526b2bf44c38e092d046fd6c6542a4169f641731d6197d15b45198d51089
EBUILD clang-python-16.0.0_pre20230107.ebuild 1181 BLAKE2B 2628ec06a37f501d0fbe285ec294050a999816997028b0813cd68cabab97139abb229688fcdd9d496a4c045fb55907ffbe9f9861ec5cc34d41bba64f8affee89 SHA512 4df861292429fe4bdce21f387db7051172950ece21607fda3a2b11504ae93f7b301a526b2bf44c38e092d046fd6c6542a4169f641731d6197d15b45198d51089
+EBUILD clang-python-17.0.0.9999.ebuild 1181 BLAKE2B 2628ec06a37f501d0fbe285ec294050a999816997028b0813cd68cabab97139abb229688fcdd9d496a4c045fb55907ffbe9f9861ec5cc34d41bba64f8affee89 SHA512 4df861292429fe4bdce21f387db7051172950ece21607fda3a2b11504ae93f7b301a526b2bf44c38e092d046fd6c6542a4169f641731d6197d15b45198d51089
MISC metadata.xml 299 BLAKE2B 2feead2cd1b35b3a43335ddd7711f8181b52bc63ee7166608914260c67528add5251349063afbef4f8cf0ec09b2cd4c3ffdd90f2c14ed60bb69ebc03888f6333 SHA512 cd745c54ab18d25bdaff18582105072574103a36cfe7c175ef740f266d00e9fc6f44c332904d23b911c939cf5bdf52973b388923099d8dd5dfef3c283b5cb685
diff --git a/dev-python/clang-python/clang-python-17.0.0.9999.ebuild b/dev-python/clang-python/clang-python-17.0.0.9999.ebuild
new file mode 100644
index 000000000000..5ec556a2ca20
--- /dev/null
+++ b/dev-python/clang-python/clang-python-17.0.0.9999.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit llvm.org python-r1
+
+DESCRIPTION="Python bindings for sys-devel/clang"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# The module is opening libclang.so directly, and doing some blasphemy
+# on top of it.
+DEPEND="
+ >=sys-devel/clang-${PV}:*
+ !sys-devel/llvm:0[clang(-),python(-)]
+ !sys-devel/clang:0[python(-)]
+"
+RDEPEND="
+ ${DEPEND}
+ ${PYTHON_DEPS}
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ test? (
+ sys-devel/clang:${LLVM_MAJOR}
+ )
+"
+
+LLVM_COMPONENTS=( clang/bindings/python )
+llvm.org_set_globals
+
+python_test() {
+ # tests rely on results from a specific clang version, so override
+ # the search path
+ local -x CLANG_LIBRARY_PATH=${BROOT}/usr/lib/llvm/${LLVM_MAJOR}/$(get_libdir)
+ local -x CLANG_NO_DEFAULT_CONFIG=1
+ "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}
+
+src_test() {
+ python_foreach_impl python_test
+}
+
+src_install() {
+ python_foreach_impl python_domodule clang
+}