summaryrefslogtreecommitdiff
path: root/dev-python/clang-python/clang-python-16.0.0_pre20230107.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-08 12:15:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-08 12:15:59 +0000
commit6a57f9ee53dc794f3d47ea68f78d6ef76d00af47 (patch)
treedc9e574f3209abd88e91e2ee0d6093f4fe78e2d3 /dev-python/clang-python/clang-python-16.0.0_pre20230107.ebuild
parent268f9f01921ccb921b794d43092c5f29c1e96c56 (diff)
gentoo auto-resync : 08:01:2023 - 12:15:59
Diffstat (limited to 'dev-python/clang-python/clang-python-16.0.0_pre20230107.ebuild')
-rw-r--r--dev-python/clang-python/clang-python-16.0.0_pre20230107.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/clang-python/clang-python-16.0.0_pre20230107.ebuild b/dev-python/clang-python/clang-python-16.0.0_pre20230107.ebuild
new file mode 100644
index 000000000000..da0feef4cef2
--- /dev/null
+++ b/dev-python/clang-python/clang-python-16.0.0_pre20230107.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit llvm.org python-r1
+
+DESCRIPTION="Python bindings for sys-devel/clang"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# The module is opening libclang.so directly, and doing some blasphemy
+# on top of it.
+DEPEND="
+ >=sys-devel/clang-${PV}:*
+ !sys-devel/llvm:0[clang(-),python(-)]
+ !sys-devel/clang:0[python(-)]
+"
+RDEPEND="
+ ${DEPEND}
+ ${PYTHON_DEPS}
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ test? (
+ sys-devel/clang:${LLVM_MAJOR}
+ )
+"
+
+LLVM_COMPONENTS=( clang/bindings/python )
+llvm.org_set_globals
+
+python_test() {
+ # tests rely on results from a specific clang version, so override
+ # the search path
+ local -x CLANG_LIBRARY_PATH=${BROOT}/usr/lib/llvm/${LLVM_MAJOR}/$(get_libdir)
+ "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}
+
+src_test() {
+ python_foreach_impl python_test
+}
+
+src_install() {
+ python_foreach_impl python_domodule clang
+}