summaryrefslogtreecommitdiff
path: root/dev-python/clang-python/clang-python-16.0.0_pre20221126.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-26 13:14:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-26 13:14:43 +0000
commit7de40ae3e1ba40671bc9aac9ebbf3f42952a036b (patch)
tree1bca877e82a542b8d0809d9de07a59ae67941c07 /dev-python/clang-python/clang-python-16.0.0_pre20221126.ebuild
parentfd3ff6e6efb0d3cf8b899956e7b48df4e2ac9615 (diff)
gentoo auto-resync : 26:11:2022 - 13:14:42
Diffstat (limited to 'dev-python/clang-python/clang-python-16.0.0_pre20221126.ebuild')
-rw-r--r--dev-python/clang-python/clang-python-16.0.0_pre20221126.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/clang-python/clang-python-16.0.0_pre20221126.ebuild b/dev-python/clang-python/clang-python-16.0.0_pre20221126.ebuild
new file mode 100644
index 000000000000..9b34adc8ac6f
--- /dev/null
+++ b/dev-python/clang-python/clang-python-16.0.0_pre20221126.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit llvm.org python-r1
+
+DESCRIPTION="Python bindings for sys-devel/clang"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# The module is opening libclang.so directly, and doing some blasphemy
+# on top of it.
+DEPEND="
+ >=sys-devel/clang-${PV}:*
+ !sys-devel/llvm:0[clang(-),python(-)]
+ !sys-devel/clang:0[python(-)]
+"
+RDEPEND="
+ ${DEPEND}
+ ${PYTHON_DEPS}
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ test? (
+ sys-devel/clang:${LLVM_MAJOR}
+ )
+"
+
+LLVM_COMPONENTS=( clang/bindings/python )
+llvm.org_set_globals
+
+python_test() {
+ # tests rely on results from a specific clang version, so override
+ # the search path
+ local -x CLANG_LIBRARY_PATH=${BROOT}/usr/lib/llvm/${LLVM_MAJOR}/$(get_libdir)
+ "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}
+
+src_test() {
+ python_foreach_impl python_test
+}
+
+src_install() {
+ python_foreach_impl python_domodule clang
+}