summaryrefslogtreecommitdiff
path: root/dev-python/clang-python/clang-python-16.0.0_pre20220918.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-21 11:25:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-21 11:25:44 +0100
commit944021dc3fb629a9c074228bf7da9f7ddf7a0caa (patch)
treef1096f56bf0c23189e2e82b909938638ac9b7efb /dev-python/clang-python/clang-python-16.0.0_pre20220918.ebuild
parent53612ae086ce9e171633a17392eb88c008650b8e (diff)
gentoo auto-resync : 21:09:2022 - 11:25:44
Diffstat (limited to 'dev-python/clang-python/clang-python-16.0.0_pre20220918.ebuild')
-rw-r--r--dev-python/clang-python/clang-python-16.0.0_pre20220918.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-python/clang-python/clang-python-16.0.0_pre20220918.ebuild b/dev-python/clang-python/clang-python-16.0.0_pre20220918.ebuild
index 2891edc42793..f0290ca4c7b1 100644
--- a/dev-python/clang-python/clang-python-16.0.0_pre20220918.ebuild
+++ b/dev-python/clang-python/clang-python-16.0.0_pre20220918.ebuild
@@ -29,12 +29,18 @@ RDEPEND="
"
BDEPEND="
${PYTHON_DEPS}
+ test? (
+ sys-devel/clang:${PV%%.*}
+ )
"
LLVM_COMPONENTS=( clang/bindings/python )
llvm.org_set_globals
python_test() {
+ # tests rely on results from a specific clang version, so override
+ # the search path
+ local -x CLANG_LIBRARY_PATH=${BROOT}/usr/lib/llvm/${PV%%.*}/$(get_libdir)
"${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
}