summaryrefslogtreecommitdiff
path: root/dev-python/clang-python/clang-python-15.0.2.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-07 19:24:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-07 19:24:36 +0100
commit7b5e4e1f63da7fb63fba5f1a9fc41866c8ae5b2f (patch)
treec9aa002e33c61cd30a2a1615be86cd9961239b0b /dev-python/clang-python/clang-python-15.0.2.9999.ebuild
parent27a61babf89122aeb64d52f4ea8f6f068b928da4 (diff)
gentoo auto-resync : 07:10:2022 - 19:24:35
Diffstat (limited to 'dev-python/clang-python/clang-python-15.0.2.9999.ebuild')
-rw-r--r--dev-python/clang-python/clang-python-15.0.2.9999.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-python/clang-python/clang-python-15.0.2.9999.ebuild b/dev-python/clang-python/clang-python-15.0.2.9999.ebuild
index f0290ca4c7b1..9b34adc8ac6f 100644
--- a/dev-python/clang-python/clang-python-15.0.2.9999.ebuild
+++ b/dev-python/clang-python/clang-python-15.0.2.9999.ebuild
@@ -30,7 +30,7 @@ RDEPEND="
BDEPEND="
${PYTHON_DEPS}
test? (
- sys-devel/clang:${PV%%.*}
+ sys-devel/clang:${LLVM_MAJOR}
)
"
@@ -40,7 +40,7 @@ llvm.org_set_globals
python_test() {
# tests rely on results from a specific clang version, so override
# the search path
- local -x CLANG_LIBRARY_PATH=${BROOT}/usr/lib/llvm/${PV%%.*}/$(get_libdir)
+ local -x CLANG_LIBRARY_PATH=${BROOT}/usr/lib/llvm/${LLVM_MAJOR}/$(get_libdir)
"${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
}