summaryrefslogtreecommitdiff
path: root/dev-python/chump
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-python/chump
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-python/chump')
-rw-r--r--dev-python/chump/Manifest2
-rw-r--r--dev-python/chump/chump-1.6.0-r1.ebuild22
-rw-r--r--dev-python/chump/chump-1.6.0.ebuild36
3 files changed, 23 insertions, 37 deletions
diff --git a/dev-python/chump/Manifest b/dev-python/chump/Manifest
index 3dd0ed738f7b..77c6528fd555 100644
--- a/dev-python/chump/Manifest
+++ b/dev-python/chump/Manifest
@@ -1,3 +1,3 @@
DIST chump-1.6.0.tar.gz 15646 BLAKE2B 8cab76e633fd4084d349115fae925c152439d06acbe629d5c23c474f2dc0a3cb1b5b727b856a9d54a82e39698b3cfd7470086a976cfc6b4870f1af02bac71f87 SHA512 d219f1b9e28dd17f834dc807cd42a288adc4f5579bf97cf6b1833e63f339bd811953c3a74cafad9021beb05cd5fddb46cf49b62a4803c62ece62d037fe38a4ee
-EBUILD chump-1.6.0.ebuild 774 BLAKE2B c7ca79c6e195959db9ad129ee22ef1b746ba7a9abd2282ce79eec9f7a87a393717c66a2201cc436b92304821e422ae7487983cf11d5831bacf073b18b6c3b206 SHA512 853e5937711f9397d10e69d711cd2356da5204a3aa5f73909fc11d612318e0f1cd609117e9fded6e8523d943b0c46600770a411352751750a32f415b401dd38e
+EBUILD chump-1.6.0-r1.ebuild 516 BLAKE2B 0aeaec7e5210ff8258ea7d4f1a603b64bd872ca09b7e1afdc428433d2bcc10608faad42d24145a05db2169faeeb72e111d1375d49ccb407feb346f5d66878210 SHA512 4f6faeb67a5e58130dd219f16f72e5ac64075054d747bd52b73c8725650502aed7a0212f0fbe4bf3b13f3cbd0c27022219899d0f35ded325a860683a17f6b0fb
MISC metadata.xml 518 BLAKE2B 126300d60995a32912c84d734b465bdc4ad7f4569aeeae7674325dbd44c177431dffb22e05341cc50e8ac0f294617c64c18c11e3b5f7bfb17eb083f48f06ffdc SHA512 bf56b4200d946208832b539649d18f450da83e2bcc31bff902ad8793fb27f823e2e4207175cc13db3ae49f1862b5889a36fa06d27ec412da647cbdb2c4286604
diff --git a/dev-python/chump/chump-1.6.0-r1.ebuild b/dev-python/chump/chump-1.6.0-r1.ebuild
new file mode 100644
index 000000000000..b46f8078b775
--- /dev/null
+++ b/dev-python/chump/chump-1.6.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="API wrapper for Pushover"
+HOMEPAGE="https://github.com/karanlyons/chump"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# 'html_theme' is unset, meaning alabaster will be used
+# and sphinx depends on it
+distutils_enable_sphinx docs
+
+# The package has no test suite
diff --git a/dev-python/chump/chump-1.6.0.ebuild b/dev-python/chump/chump-1.6.0.ebuild
deleted file mode 100644
index 6ee3f01c296e..000000000000
--- a/dev-python/chump/chump-1.6.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="API wrapper for Pushover"
-HOMEPAGE="https://github.com/karanlyons/chump"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-DEPEND="
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-
-# The package has no test suite
-
-python_prepare_all() {
- sed -i "/'sphinx.ext.intersphinx'/d" docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- # Force sphinx to use the standard theme
- READTHEDOCS=True sphinx-build docs docs/_build/html || die
- HTML_DOCS=( docs/_build/html/. )
- fi
-}