summaryrefslogtreecommitdiff
path: root/dev-python/cherrypy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-14 20:44:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-14 20:44:04 +0000
commit46227d4bea72a4d588141f40667699df3aeef2b0 (patch)
treefe9f107ad101a24dfb24866d1ae2a933f9f8bbe8 /dev-python/cherrypy
parent349911d45bc38140a6a32c0971e0ab5cdc4de9ac (diff)
gentoo auto-resync : 14:12:2023 - 20:44:04
Diffstat (limited to 'dev-python/cherrypy')
-rw-r--r--dev-python/cherrypy/Manifest2
-rw-r--r--dev-python/cherrypy/cherrypy-18.9.0.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/cherrypy/Manifest b/dev-python/cherrypy/Manifest
index bb284aca26cf..f4692956615c 100644
--- a/dev-python/cherrypy/Manifest
+++ b/dev-python/cherrypy/Manifest
@@ -1,4 +1,6 @@
AUX cherrypy-18.8.0-py312.patch 1167 BLAKE2B 0c994cebfefa44fe0ea13210046f391c911db0633adbf1db70013421b4219f63b4986cc3a18fbfbc708fc806fdab5c78b51036dd6c5a4863cf249071b8df2f05 SHA512 06d647b824de4b1fef2a596f323944440f6dd1ef0cdf0fa088db3544f45a63deb9980b2d3588309f06ad6ff97742588be5363c29adbf0b69766760c67ecee179
DIST CherryPy-18.8.0.tar.gz 622679 BLAKE2B 673f9a103a901161ee801656fa37fa0a4fcd2d9276a5231e48c1663264eb7f922d5d862018995a345a8485252416fa0229da49b8d265288efce2dccd37d79ff8 SHA512 abacc995c1757b8d0171d57eb59b6e5931c46019d8f0f43479e334bb4f58b61a27541d9d0997d665f81905bc3c89e42d40d8e5a6e3a5f9bf251bc9089ceb5249
+DIST CherryPy-18.9.0.tar.gz 631900 BLAKE2B 5bc0d4315f6b9300ba8fc122858554a6b6476f78ac1fb31b1635707488a4a300e359d2e368dde9996c202a8f42100ef09e298fb923f955e92d7906ed970d2ba9 SHA512 ed2beacedd3417214f45e59567f2a1faf5964745a545360db2f61251a39f50f2a833745832a2c900673029d98062f7e1813db6c342585f8d2bbae0be423edb3a
EBUILD cherrypy-18.8.0.ebuild 1837 BLAKE2B a1ca1f5565c3a43fa180a8624bd42d4b7c256396c52b283fc8131f0d731bd0cfa044ca6c3c9f2808b75885b2b47ecf5ab2b527d84f78fad094ed338c74fc1c60 SHA512 d6f56161f87956325757dfece47d84b32b5c9582a4bad2dbc3a322d678c500de72b97c54a946f22d48a6ff07e750fe3a7567999c56c46bf2513176479df8a124
+EBUILD cherrypy-18.9.0.ebuild 1738 BLAKE2B 2dc155b1ab26f060dacf5ae6de26c29d0026f4bf759e5d050cd24a0e01e8054c3e032d536326c0d6141be34e16da2244806cd670b96f45b7377b661fb5acbb94 SHA512 7200227bf4d7980897da47f0c117969e9780b9247d24eb640d2e8f63d65637b224534a2d0578ae45a56ee00b6b59b53fa37395d9278fbdadcfb660ac81eb2395
MISC metadata.xml 469 BLAKE2B 8a5e41d7cee996975da9df7a30172bfebd1b715581bc5e4de1934a97332af16a18c928b33ad088723618f3dd694101639702c5d6c2619e3db46c488992aa67a3 SHA512 d08a8114dcdefa5e27a2382604953c7635d376f941f92a128e229f42c3b236da0e36287182c2be735b624566a6bb5dd1c3541bf67396e33169f86e6dd0d0c09a
diff --git a/dev-python/cherrypy/cherrypy-18.9.0.ebuild b/dev-python/cherrypy/cherrypy-18.9.0.ebuild
new file mode 100644
index 000000000000..6913dc90e893
--- /dev/null
+++ b/dev-python/cherrypy/cherrypy-18.9.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN="CherryPy"
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CherryPy is a pythonic, object-oriented HTTP framework"
+HOMEPAGE="
+ https://cherrypy.dev/
+ https://github.com/cherrypy/cherrypy/
+ https://pypi.org/project/CherryPy/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="ssl test"
+
+RDEPEND="
+ >=dev-python/cheroot-8.2.1[${PYTHON_USEDEP}]
+ >=dev-python/portend-2.1.1[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/zc-lockfile[${PYTHON_USEDEP}]
+ dev-python/jaraco-collections[${PYTHON_USEDEP}]
+ ssl? (
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/routes[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/objgraph[${PYTHON_USEDEP}]
+ dev-python/path[${PYTHON_USEDEP}]
+ dev-python/requests-toolbelt[${PYTHON_USEDEP}]
+ dev-python/pytest-services[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e '/cov/d' pytest.ini || die
+ # upstream has been using xfail to mark flaky tests, then added
+ # xfail_strict... not a good idea
+ sed -i -e '/xfail_strict/d' pytest.ini || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
+ # broken by changes in traceback output
+ cherrypy/test/test_request_obj.py::RequestObjectTests::testErrorHandling
+ cherrypy/test/test_tools.py::ToolTests::testHookErrors
+ )
+
+ epytest
+}