summaryrefslogtreecommitdiff
path: root/dev-python/cherrypy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-10 05:25:01 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-10 05:25:01 +0000
commit456dbeaab3e2f71f527eae542ab44d1e372b0655 (patch)
tree5cee708ec6e4b4e530a4337e7389598dc7cd6144 /dev-python/cherrypy
parent65737cf14a7220bd9a487aa2af4ae0e79bd23e86 (diff)
gentoo resync : 10.01.2018
Diffstat (limited to 'dev-python/cherrypy')
-rw-r--r--dev-python/cherrypy/Manifest2
-rw-r--r--dev-python/cherrypy/cherrypy-13.1.0.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/cherrypy/Manifest b/dev-python/cherrypy/Manifest
index 8213844c8199..4d9d2b488380 100644
--- a/dev-python/cherrypy/Manifest
+++ b/dev-python/cherrypy/Manifest
@@ -1,3 +1,5 @@
+DIST CherryPy-13.1.0.tar.gz 687221 BLAKE2B ab9c8f50026e26d171877e4e68f1c5a53fa8519190bcc577e12999cdf8a7f52be37f4ba9ed83a276a9f33676839ec63bff68aa8f9f51ddf15557e09123bf2530 SHA512 c32cf009d6a5b557560a00cde0f47a01ae481c7f60b7f340e5c99bf2d7c757e7c7cbf3ef2f4f71c172057aa09ca332f2d211cc97623ea29ba9f17287c7bc42dd
DIST CherryPy-3.8.0.tar.gz 433711 BLAKE2B e1b4a554138a61e8c6313c3055723583d812e573a352d67bd5448f799e4f2f22694b800810b53cd041c665e46d9555b471d1da91c252ade96459778d7a5c07fa SHA512 25f84093e30d814c0980f7d77b98492113470c3297c66ee8652e40650757f8e2b7db01bb8de6d7a1ea9b4bed8b764502b1f563ac6f0d082970bc2d46739d19c2
+EBUILD cherrypy-13.1.0.ebuild 1260 BLAKE2B 39552288150a34e7624008f6ed565d3e0b789c71c050f13b8d7cb3b09884086e653a126d4d277c6e71ade4aecf305c1a7f10f07d329f32abba126a84363ab783 SHA512 732a835396fec4fcc8f949fb2b7f6f5f9c93e7fe3ebeb12e8a978256ee8108cad1c0e877951534e6ae21307cf6cb25bda39d0569df65e71217139a6b5a3f9dd7
EBUILD cherrypy-3.8.0.ebuild 1661 BLAKE2B f3ebb5b8bf5ea529d9a3be6041b93f1490249e88444d718ef095511dea4af4f97c73841bd2301e5b084ce78c6b76b547cbd9ce72351276c6b411d26e4374f51d SHA512 7149cfa87ee95bed2f95e0107425e476155902f411a7261b4b05e8eb002aa3f4730d3c3469aad48ead90fe5838baa14b2e4e441e0d1848e013c88e9e8ecbf195
MISC metadata.xml 321 BLAKE2B 6636b11693e6e9d09f579bc88b203bd7c41f67222887365de5db2c3aca4c34d8cb2e341f217240ce562f43d60e78221442c12b08f2f7e516c36e06d928a9a995 SHA512 c777da5d545e3d626d663830437ec91a8f228c58734c7df4e4a16f0609904a5ad4613310d2d05b4e8ea89053371ad0bd4f0624137afe54ff6c4f5d9eef734d10
diff --git a/dev-python/cherrypy/cherrypy-13.1.0.ebuild b/dev-python/cherrypy/cherrypy-13.1.0.ebuild
new file mode 100644
index 000000000000..02dfe13cae17
--- /dev/null
+++ b/dev-python/cherrypy/cherrypy-13.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_P="CherryPy-${PV}"
+
+DESCRIPTION="CherryPy is a pythonic, object-oriented HTTP framework"
+HOMEPAGE="http://www.cherrypy.org/ https://pypi.python.org/pypi/CherryPy"
+SRC_URI="mirror://pypi/C/CherryPy/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/cheroot-5.9.1[${PYTHON_USEDEP}]
+ >=dev-python/portend-2.1.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.11.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
+ dev-python/path-py[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # UnicodeEncodeError: 'ascii' codec can't encode character u'\u2603' in position 0: ordinal not in range(128)
+ sed -e 's|@pytest.mark.xfail(py27_on_windows|@pytest.mark.xfail(sys.version_info < (3,)|' \
+ -i cherrypy/test/test_static.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test -v || die "tests failed under ${EPTYHON}"
+}