summaryrefslogtreecommitdiff
path: root/dev-python/cheroot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-20 13:02:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-20 13:02:32 +0000
commit65c1a6f8d7210639cbdc1565ccee4758f45dfc45 (patch)
treed7bea8e8d228e76b177eccb0ffc1f45a58a1e2f7 /dev-python/cheroot
parentc4f077d9f57bf57fcded75904bf512075191d2d2 (diff)
gentoo auto-resync : 20:11:2022 - 13:02:32
Diffstat (limited to 'dev-python/cheroot')
-rw-r--r--dev-python/cheroot/Manifest3
-rw-r--r--dev-python/cheroot/cheroot-9.0.0.ebuild79
-rw-r--r--dev-python/cheroot/files/cheroot-9.0.0-remove-pypytools-dep.patch21
3 files changed, 103 insertions, 0 deletions
diff --git a/dev-python/cheroot/Manifest b/dev-python/cheroot/Manifest
index c63026c1447b..362343c08431 100644
--- a/dev-python/cheroot/Manifest
+++ b/dev-python/cheroot/Manifest
@@ -1,4 +1,7 @@
AUX cheroot-8.6.0-remove-pypytools-dep.patch 2757 BLAKE2B 97628fd6590dbe41e34bf0b93bc1062c424097aeea26a86891e2d2fc049fb7ee7a990fc9b9d3dba9406bdd344e3c25cdd08907aaac11e64d78c73b3ccd9b3fa5 SHA512 ddc88d93c795ea25c56d0b2a1bfee1b0f9c900ec2594d69aa91c639575c86c1fb89accc95992587db76d5c4e438a34f2eceac480c60a5470aee5ecd996140e44
+AUX cheroot-9.0.0-remove-pypytools-dep.patch 731 BLAKE2B 9b0cd967e10d65a14ddc17d411f84e20641f73f89a0094be99f36c7c2924ee18e938ec3e7cd3852a90f6e2e0fb3efcec76652b0c6f2ab1d4b719769d822eab52 SHA512 5e3b9c8ed9ba6df645df9fa0eb9787f85ee01bf7a4dfa163c9d6ee281b65cab6303486af45f0b309f13b34e7567f11894048daf2cd1edc8bd1a1e594216317c3
DIST cheroot-8.6.0.tar.gz 134779 BLAKE2B 97d1a9bf0a8d72d3204972934aa3ac4c97246b413edebd9f38caa802a5343acc426f137addfdc0faec58f6af2d62bc22023e93b14e1b0b07f6be9ffb12e78306 SHA512 26e48c935fe32d4ce3cf6ae20b5b272416ca53bd8496527c2958ec2ebe87529c831f283ae900e13271b610e39531b682df0376935ecc3bcfcca11c299cd2a893
+DIST cheroot-9.0.0.tar.gz 152562 BLAKE2B 5f5dd172cfc8fdd1318b22fc27060444a34343b6b83bbda4bd40c16d7cb0568c356f5fd14b0a7cdc74895d6707077ec54fcae54fb29b0d16a7c06e2cd36b1ee7 SHA512 86ea0dd2cb4cde25f86b489b1d0bb27e3e7c1ba5449759ccecaae689cdcb349b968fd0c8fb8bc8273deff5e32a078bf40f4342f0c5a1f53bb8d2b968f44a453b
EBUILD cheroot-8.6.0-r1.ebuild 1872 BLAKE2B 4392d43c6eca572c07129963eef6d8ea0fed1a97dea212fe8eba15d1a12a9860e506a3ec1e41bc726272aae9a5228740ae8a02dfdb6b8e780c4bf8da3c5f05bf SHA512 d25b25098dd127bbf59f089b457599271e36eec82746e57b105934838133adab76fae1b65a7132fb129ac70eb62df4dbb982fa5e660e096ff0c75f3f05d68122
+EBUILD cheroot-9.0.0.ebuild 1969 BLAKE2B 0deffd50d152435a3171f587423f190663850c84184e0c9b7d5745949fd9af7bdef4c8f817ce4044b86e7f76e9573fab687a06341d4cd8c67c0b53a859a86d2a SHA512 58556ac85c2ae0d2e0eb9a264806ea59af91fe646440ff11575b089e45f1f8427668b47edf5c556709a5dc859fac1c3f7a3f541509f1b6e08180f5102c11f6e7
MISC metadata.xml 391 BLAKE2B 1c9c2af2c1a8bcd3f1c426a87d1a2a97fb88a9a30f9c2f1802b8885329277fcfde1deadf635e419cd7f85a5685639709be33aa746d9f7a04c3ac7d832d084b42 SHA512 c194e8bed8d082ed4ce3f2a7f608085fdcf2ab8b7c730e5c6ad7438cf177ed1892565cdff0feda564681f59bf6aefc327e3d24da0a543c0f043934af27873e95
diff --git a/dev-python/cheroot/cheroot-9.0.0.ebuild b/dev-python/cheroot/cheroot-9.0.0.ebuild
new file mode 100644
index 000000000000..f16d3e17d8a7
--- /dev/null
+++ b/dev-python/cheroot/cheroot-9.0.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="High-performance, pure-Python HTTP server used by CherryPy"
+HOMEPAGE="
+ https://cherrypy.dev/
+ https://pypi.org/project/cheroot/
+ https://github.com/cherrypy/cheroot/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test-rust"
+
+RDEPEND="
+ >=dev-python/six-1.11.0[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-2.6[${PYTHON_USEDEP}]
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/jaraco-context[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+ dev-python/portend[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-1.11.0[${PYTHON_USEDEP}]
+ dev-python/requests-toolbelt[${PYTHON_USEDEP}]
+ dev-python/requests-unixsocket[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ test-rust? (
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e '/--cov/d' \
+ -e '/--testmon/d' \
+ -e '/--numproc/d' \
+ -i pytest.ini || die
+
+ # broken
+ sed -i -e '/False.*localhost/d' cheroot/test/test_ssl.py || die
+ # pypytools is py2 stuff
+ sed -i -e '/pypytools/d' cheroot/test/test_server.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires pypytools, see above
+ cheroot/test/test_server.py::test_high_number_of_file_descriptors
+ )
+
+ local EPYTEST_IGNORE=()
+ if ! has_version "dev-python/pyopenssl[${PYTHON_USEDEP}]" ||
+ ! has_version "dev-python/trustme[${PYTHON_USEDEP}]"
+ then
+ EPYTEST_IGNORE+=(
+ cheroot/test/test_ssl.py
+ )
+ fi
+
+ epytest -p no:flaky
+}
diff --git a/dev-python/cheroot/files/cheroot-9.0.0-remove-pypytools-dep.patch b/dev-python/cheroot/files/cheroot-9.0.0-remove-pypytools-dep.patch
new file mode 100644
index 000000000000..8e79b2c776f4
--- /dev/null
+++ b/dev-python/cheroot/files/cheroot-9.0.0-remove-pypytools-dep.patch
@@ -0,0 +1,21 @@
+diff --git a/cheroot/test/test_server.py b/cheroot/test/test_server.py
+index 5e0a6832..6f480f40 100644
+--- a/cheroot/test/test_server.py
++++ b/cheroot/test/test_server.py
+@@ -12,8 +12,6 @@ import pytest
+ import requests
+ import requests_unixsocket
+
+-from pypytools.gc.custom import DefaultGc
+-
+ from .._compat import bton, ntob
+ from .._compat import IS_LINUX, IS_MACOS, IS_WINDOWS, SYS_PLATFORM
+ from ..server import IS_UID_GID_RESOLVABLE, Gateway, HTTPServer
+@@ -324,6 +322,7 @@ def test_peercreds_unix_sock_with_lookup(
+ assert peercreds_text_resp.text == expected_textcreds
+
+
++@pytest.mark.skip("pypytools not packaged")
+ @pytest.mark.skipif(
+ IS_WINDOWS,
+ reason='This regression test is for a Linux bug, '