summaryrefslogtreecommitdiff
path: root/dev-python/cheroot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /dev-python/cheroot
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'dev-python/cheroot')
-rw-r--r--dev-python/cheroot/Manifest2
-rw-r--r--dev-python/cheroot/cheroot-8.5.2.ebuild9
2 files changed, 5 insertions, 6 deletions
diff --git a/dev-python/cheroot/Manifest b/dev-python/cheroot/Manifest
index 14aee3685631..eae74499afae 100644
--- a/dev-python/cheroot/Manifest
+++ b/dev-python/cheroot/Manifest
@@ -1,3 +1,3 @@
DIST cheroot-8.5.2.tar.gz 113183 BLAKE2B a3b60a9df3f34913cfb8c99fbdc8580ea436710c7979e296c18a6981f54bb959d6a300f4cf9d4e608fe2987f58d5fc6d2b8f57bca800e461d31c77ac61fd6b01 SHA512 245c4157f5e11741d94375099878ef5b31945412a2b02961502e762b9770fd968f4f977fe2d74744aa6596c668079d7f07b6f129fa11438783a95d3a5ee088fa
-EBUILD cheroot-8.5.2.ebuild 1622 BLAKE2B 1a84b43d6ecc32d815ac3eada365eb56ff0bc5567f093f096bbbd6f05fa23a12fd38a39b97ac1def2d113770856406bcd736c9533ebdb3688701810ac91ef236 SHA512 9453466be06a99467328b52031d330be2e85bb5d84e2a9724abe72ab1cc2de9116d6b8d848c082234ecebaca6a68a8d11dd9d1130199244c22dc2c1ef854aa5a
+EBUILD cheroot-8.5.2.ebuild 1533 BLAKE2B 221828f25d3b852c8efd53393941ef6b76793616ea686bad24a5c1e9280c234c84f103184b3cc2cb0632f7b32c1d22f8dde748a86d97b31aa83fb8a6dc355c68 SHA512 7390bf8a7fa356ecbed3deaab9cd45ba76c1bedb6233f724a3653409af7d9316afdf4bd3020c4ca4b1e03a8ae020dd7653f7dd50a3769c58e2dacb5671976b31
MISC metadata.xml 495 BLAKE2B 4194775afacc99b4983275505dd45471a7ca4305a6cfb37d8fe80fdc00d196da1c2722940d2ae13408de0c13c92c7a2a01ef153b35f49f8ccb9d7df2f605dceb SHA512 710108fdb8ddda277cceea3d57a3ef716e7a67067e658f9719a793f9ba7fd04e8a1e4482c68c23ba458e29e85b9b233d72ec485ab8c585703f411fc32051f256
diff --git a/dev-python/cheroot/cheroot-8.5.2.ebuild b/dev-python/cheroot/cheroot-8.5.2.ebuild
index ad187eb5f9bd..7e8619853279 100644
--- a/dev-python/cheroot/cheroot-8.5.2.ebuild
+++ b/dev-python/cheroot/cheroot-8.5.2.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
-DESCRIPTION="Cheroot is the high-performance, pure-Python HTTP server used by CherryPy."
+DESCRIPTION="High-performance, pure-Python HTTP server used by CherryPy"
HOMEPAGE="https://cherrypy.org/
https://pypi.org/project/cheroot/
https://github.com/cherrypy/cheroot/"
@@ -57,5 +56,5 @@ python_prepare_all() {
python_test() {
cd "${BUILD_DIR}" || die
- pytest -vv || die "Tests failed with ${EPYTHON}"
+ epytest
}