summaryrefslogtreecommitdiff
path: root/dev-python/cheroot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/cheroot
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/cheroot')
-rw-r--r--dev-python/cheroot/Manifest2
-rw-r--r--dev-python/cheroot/cheroot-8.6.0-r1.ebuild (renamed from dev-python/cheroot/cheroot-8.6.0.ebuild)17
2 files changed, 10 insertions, 9 deletions
diff --git a/dev-python/cheroot/Manifest b/dev-python/cheroot/Manifest
index 248d78c1e300..1910b42c5dab 100644
--- a/dev-python/cheroot/Manifest
+++ b/dev-python/cheroot/Manifest
@@ -1,4 +1,4 @@
AUX cheroot-8.6.0-remove-pypytools-dep.patch 2757 BLAKE2B 97628fd6590dbe41e34bf0b93bc1062c424097aeea26a86891e2d2fc049fb7ee7a990fc9b9d3dba9406bdd344e3c25cdd08907aaac11e64d78c73b3ccd9b3fa5 SHA512 ddc88d93c795ea25c56d0b2a1bfee1b0f9c900ec2594d69aa91c639575c86c1fb89accc95992587db76d5c4e438a34f2eceac480c60a5470aee5ecd996140e44
DIST cheroot-8.6.0.tar.gz 134779 BLAKE2B 97d1a9bf0a8d72d3204972934aa3ac4c97246b413edebd9f38caa802a5343acc426f137addfdc0faec58f6af2d62bc22023e93b14e1b0b07f6be9ffb12e78306 SHA512 26e48c935fe32d4ce3cf6ae20b5b272416ca53bd8496527c2958ec2ebe87529c831f283ae900e13271b610e39531b682df0376935ecc3bcfcca11c299cd2a893
-EBUILD cheroot-8.6.0.ebuild 1904 BLAKE2B 85849f7216f607607857ca4a0055b5bc618ba6dd98e1d3fec45f1beff2bde329f27bc41202ee2f3e66e44f51db20cabfad7a17287d7a733e522526c19200129d SHA512 6506facf143da2ad138a0dee835e2f28762a76eb151118da535aede3448f31f29a8328aea54ad2214abe5a974507dd267a0d3852c45f82d9775160fd16a33404
+EBUILD cheroot-8.6.0-r1.ebuild 1832 BLAKE2B e2f2b5ea27b7d133a5e6f42d6a05149cf148316e19ad8a8563ab41c6a2c241b5649154714d6384c28ed1af6cfdc2ae81e32f8e8dad2b7e26a5d2d77708951993 SHA512 336eac3a709650b17df11ed5a4b031109bd145c6eb3866d0c970f8ad959a160b0a5b7b3ecf53fe48e7cc66311a3d4261c362425217eb94cfa6a1c35064ccee48
MISC metadata.xml 391 BLAKE2B 1c9c2af2c1a8bcd3f1c426a87d1a2a97fb88a9a30f9c2f1802b8885329277fcfde1deadf635e419cd7f85a5685639709be33aa746d9f7a04c3ac7d832d084b42 SHA512 c194e8bed8d082ed4ce3f2a7f608085fdcf2ab8b7c730e5c6ad7438cf177ed1892565cdff0feda564681f59bf6aefc327e3d24da0a543c0f043934af27873e95
diff --git a/dev-python/cheroot/cheroot-8.6.0.ebuild b/dev-python/cheroot/cheroot-8.6.0-r1.ebuild
index af8d3eaf4567..aae772bf949c 100644
--- a/dev-python/cheroot/cheroot-8.6.0.ebuild
+++ b/dev-python/cheroot/cheroot-8.6.0-r1.ebuild
@@ -3,14 +3,18 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
inherit distutils-r1
DESCRIPTION="High-performance, pure-Python HTTP server used by CherryPy"
-HOMEPAGE="https://cherrypy.org/
+HOMEPAGE="
+ https://cherrypy.dev/
https://pypi.org/project/cheroot/
- https://github.com/cherrypy/cheroot/"
-SRC_URI="mirror://pypi/C/${PN/c/C}/${P}.tar.gz"
+ https://github.com/cherrypy/cheroot/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
@@ -22,8 +26,8 @@ RDEPEND="
dev-python/jaraco-functools[${PYTHON_USEDEP}]
"
BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
test? (
- ${RDEPEND}
dev-python/jaraco-context[${PYTHON_USEDEP}]
dev-python/jaraco-text[${PYTHON_USEDEP}]
dev-python/portend[${PYTHON_USEDEP}]
@@ -47,8 +51,6 @@ PATCHES=(
distutils_enable_tests pytest
python_prepare_all() {
- sed -e "s/use_scm_version=True/version='${PV}'/" -i setup.py || die
- sed -e '/setuptools_scm/d' -i setup.cfg || die
sed -e '/--cov/d' \
-e '/--testmon/d' \
-e '/--numproc/d' \
@@ -71,6 +73,5 @@ python_test() {
)
fi
- cd "${BUILD_DIR}" || die
epytest
}