summaryrefslogtreecommitdiff
path: root/dev-python/cheetah-docs/cheetah-docs-0.9.16_alpha1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/cheetah-docs/cheetah-docs-0.9.16_alpha1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/cheetah-docs/cheetah-docs-0.9.16_alpha1.ebuild')
-rw-r--r--dev-python/cheetah-docs/cheetah-docs-0.9.16_alpha1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/cheetah-docs/cheetah-docs-0.9.16_alpha1.ebuild b/dev-python/cheetah-docs/cheetah-docs-0.9.16_alpha1.ebuild
new file mode 100644
index 000000000000..608379b1d81d
--- /dev/null
+++ b/dev-python/cheetah-docs/cheetah-docs-0.9.16_alpha1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Documentation for Cheetah templates"
+HOMEPAGE="http://www.cheetahtemplate.org/"
+SRC_URI="mirror://sourceforge/cheetahtemplate/CheetahDocs-${PV/_alpha/a}.tgz"
+
+IUSE=""
+LICENSE="OPL"
+KEYWORDS="~amd64 ~ia64 ppc x86"
+SLOT="0"
+
+S=${WORKDIR}/CheetahDocs
+
+RESTRICT="binchecks strip"
+
+src_install() {
+ ecvs_clean
+
+ dodoc *.txt TODO
+ dohtml -r devel_guide_html devel_guide_html_multipage \
+ users_guide_html users_guide_html_multipage \
+ OnePageTutorial.html
+
+ # Install the source code.
+ insinto /usr/share/doc/${PF}
+ doins -r devel_guide_src users_guide_src
+
+ doins *.ps *.pdf
+}