summaryrefslogtreecommitdiff
path: root/dev-python/chardet/chardet-5.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-02 14:56:29 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-02 14:56:29 +0000
commitcc2c9e975285d6fb1be1b71d18ba4cca7991b921 (patch)
tree9b90516b35ff9055066e5b8f2e4a2ce3b6a71b38 /dev-python/chardet/chardet-5.1.0.ebuild
parent5a1e5a6812ca9c9555657cce48fe09d2ffa44401 (diff)
gentoo auto-resync : 02:12:2022 - 14:56:29
Diffstat (limited to 'dev-python/chardet/chardet-5.1.0.ebuild')
-rw-r--r--dev-python/chardet/chardet-5.1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/chardet/chardet-5.1.0.ebuild b/dev-python/chardet/chardet-5.1.0.ebuild
new file mode 100644
index 000000000000..1a0f32883fb2
--- /dev/null
+++ b/dev-python/chardet/chardet-5.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Universal encoding detector"
+HOMEPAGE="
+ https://github.com/chardet/chardet/
+ https://pypi.org/project/chardet/
+"
+SRC_URI="
+ https://github.com/chardet/chardet/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # super flaky test
+ # https://github.com/chardet/chardet/issues/256
+ test.py::test_detect_all_and_detect_one_should_agree
+)