summaryrefslogtreecommitdiff
path: root/dev-python/chameleon/chameleon-4.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-26 11:27:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-26 11:27:54 +0100
commit25e2c97a4a6f12a367115508fc86d34fe76a6f5e (patch)
tree68acc191d796190f572dc374002717fec321e616 /dev-python/chameleon/chameleon-4.2.0.ebuild
parent1aa38370b2506ce90ad64cd4e18968d6612ebea5 (diff)
gentoo auto-resync : 26:09:2023 - 11:27:54
Diffstat (limited to 'dev-python/chameleon/chameleon-4.2.0.ebuild')
-rw-r--r--dev-python/chameleon/chameleon-4.2.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/chameleon/chameleon-4.2.0.ebuild b/dev-python/chameleon/chameleon-4.2.0.ebuild
new file mode 100644
index 000000000000..aef73bc7e9f2
--- /dev/null
+++ b/dev-python/chameleon/chameleon-4.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN^}
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fast HTML/XML template compiler for Python"
+HOMEPAGE="
+ https://github.com/malthe/chameleon/
+ https://pypi.org/project/Chameleon/
+"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests unittest
+
+src_test() {
+ cd src || die
+ distutils-r1_src_test
+}