summaryrefslogtreecommitdiff
path: root/dev-python/cgroup-utils/cgroup-utils-0.8-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/cgroup-utils/cgroup-utils-0.8-r1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/cgroup-utils/cgroup-utils-0.8-r1.ebuild')
-rw-r--r--dev-python/cgroup-utils/cgroup-utils-0.8-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/cgroup-utils/cgroup-utils-0.8-r1.ebuild b/dev-python/cgroup-utils/cgroup-utils-0.8-r1.ebuild
new file mode 100644
index 000000000000..ef958fcdcceb
--- /dev/null
+++ b/dev-python/cgroup-utils/cgroup-utils-0.8-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Tools and libraries for control groups of Linux"
+HOMEPAGE="https://github.com/peo3/cgroup-utils"
+SRC_URI="https://github.com/peo3/cgroup-utils/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8-tests-builddir.patch
+
+ # Upstream: https://github.com/peo3/cgroup-utils/pull/12
+ "${FILESDIR}"/${PN}-0.8-tests-mountpoint.patch
+)
+
+python_test() {
+ sh ./test_all.sh || die
+}