summaryrefslogtreecommitdiff
path: root/dev-python/cfn-lint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-01 10:13:22 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-01 10:13:22 +0100
commitfbf0c3d1b463bf45fb0e9f119bec3424d6a44a4f (patch)
tree0577a4fd370ca08d8ba17250042db808c880e3d3 /dev-python/cfn-lint
parentf3197c619cca64ce3915f6524d47c135b68a47f7 (diff)
gentoo auto-resync : 01:09:2023 - 10:13:22
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest2
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.79.8.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 00a257493d99..01123140c665 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,5 +1,7 @@
DIST cfn-lint-0.78.2.tar.gz 3533168 BLAKE2B 043991f54cd6d793fc91af8d911184d6a98be34fb9a5735fd45113405707802fd0427654cf21de4c15b62fecd149a5d21af1b96ddf8810eb6ea507b5798a8d94 SHA512 63c575ba282cb097b321a8a00e70b1afdffd3c349e031d8a1ff2aacaeb397824e9f19968e2107a00d1aae6d7f644f376174ecc80389ee581727935867d73872e
DIST cfn-lint-0.79.7.tar.gz 3637937 BLAKE2B bfd4583ecbb64cc7dc0b1db91b3afb0859d660be8d3e7d57c427fc6f3cd89b864cd60bbfc0450a2aa7dadb4fa51f275867307bd0fd510d03efd42c2f53b33ee1 SHA512 aa3e89006d92cfb72c191716fc2553aaa8e92d5d5d64f7ebce6459d10abf7d057ee41ca667d99f6153604ae92be98b69425e5e91b7ffc1cbf82466c2c8a3ebd3
+DIST cfn-lint-0.79.8.tar.gz 3707474 BLAKE2B fe8790af88f82f7b12ea79cd07567047a0e0a1093d0adfd9b6e388fa2e53756773786c20a2d6231c7d6497748db1ce6d1aa38d4798aae3211e0cb756690e71e2 SHA512 6ae0dacc8fa5447ce8302b32d0e91f4e7c9367eb6f8db1951f19e620b8a9e3afa30c8013c907e2b1faf92daadecc81ac852470fadc30d036669e5e88b236715c
EBUILD cfn-lint-0.78.2.ebuild 2039 BLAKE2B 500f21b214a4644cda448dfe35c6f175a5a197a48dc4b530f79e5353d592bc0d756b7dab52c77641d956129406c2ba6a96beb29c6472747c6c545b783b3232a0 SHA512 af997b4b4f0181a7f213e05c865a1e37f3bd0a3d23c90137e43c462fc6c38dbd18ebff7510f4aaedcf6c976a42e707f3310687d8dd20db9c51171e7cd5db77b8
EBUILD cfn-lint-0.79.7.ebuild 2041 BLAKE2B 586c1d2db5839c41539181df6596b4177a552e6e8c45ee39139660e72fa16f390576fc94dd43a34ce3544547ffee318190142c818c99211d9f5486be20088ef4 SHA512 101f8ddfbd2dcebe6641388af02aa9418dc7b1898d10fe58361cb4e8f53f3f13e0dcc87f2db45fa34de65e0e543f126e48dc06ca4aa939dcc9732db99c960bca
+EBUILD cfn-lint-0.79.8.ebuild 2041 BLAKE2B 586c1d2db5839c41539181df6596b4177a552e6e8c45ee39139660e72fa16f390576fc94dd43a34ce3544547ffee318190142c818c99211d9f5486be20088ef4 SHA512 101f8ddfbd2dcebe6641388af02aa9418dc7b1898d10fe58361cb4e8f53f3f13e0dcc87f2db45fa34de65e0e543f126e48dc06ca4aa939dcc9732db99c960bca
MISC metadata.xml 583 BLAKE2B 9f73e2b92e5cfa2ad59f5c8e5d91bdd3aa9eba3fa722b93b388cffea42020db7e7441bab5749432812934a4514d3e9104e6d897e1d115afa5ed237757bd48c03 SHA512 1866a349855ae4e248498b7aabd6ce4c4e10ea58731df4bfa13500f61dc041da6dbd7420e7d6a78fad46d5cf00bd7ef2d0c4c7d6819a21b3a5031b0d49588a19
diff --git a/dev-python/cfn-lint/cfn-lint-0.79.8.ebuild b/dev-python/cfn-lint/cfn-lint-0.79.8.ebuild
new file mode 100644
index 000000000000..7071d59d0406
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.79.8.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.71.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema_to_python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ >=dev-python/sarif_om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -e '/jsonschema/s:,<4.18::' -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}