summaryrefslogtreecommitdiff
path: root/dev-python/cfn-lint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-12 14:22:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-12 14:22:05 +0100
commit7c68db06bb531670c1261374c0133d652b476bd7 (patch)
tree5bbbde86ec021664b3c6dfaf90e1175f8378949c /dev-python/cfn-lint
parent0987983e8588d2819bb2ceb029792d511cee0bda (diff)
gentoo auto-resync : 12:08:2022 - 14:22:05
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest2
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.61.5.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index c28ad5a5ae61..ce9976fdd51a 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,5 +1,7 @@
DIST cfn-lint-0.61.3.gh.tar.gz 9528542 BLAKE2B 27f5c82c09a7c1dde520189647480032faf808089083ca45a9a2a24e4c158cb8e62ee6ae2f906d6c68021cc34b654ff46c9402876e09dd3330115dead5db44a8 SHA512 db5369a12d88754f6241b4ef529b53d142a80bfcb0c58ac7ec03217e7e4cb7e53f3fde1dde45dfdac82ab3fde4b885bb40dae3076b85edf34ca68cc73dc5aeb1
DIST cfn-lint-0.61.4.gh.tar.gz 9556069 BLAKE2B 71572546d7e523c11214e32130a7d52461580e487b514846137e6592cb7a1786414556e4bea191aa2e4dddaf338c24e8ea9001e617221ea74b03bd0ea900a5a9 SHA512 fd85af770b5b519c9de4df0acbbaa66a8a7f61efd210a793c2e28ad9e6d6ed2d8b3042ca41d7743b2bc4dc0446b42ea2929cba454fdbf097a482a7c268e04000
+DIST cfn-lint-0.61.5.gh.tar.gz 9580886 BLAKE2B 0e83a604bc8761cd6007039cc28d90e471ef3cd3c542e7ce977d290638bcbff2b196c5d3c5f23b8d6db064b867ab594360dedb86494aba955c065c7cbad8b519 SHA512 14a1c282f1d87ce5ddd231f92e01a4edd85a62802f2335ba95470acaa0d8deb0306433124f3d1bea6c965ebfe5b30145431087a71cb1e8b953bf94b5d691bcbf
EBUILD cfn-lint-0.61.3.ebuild 1638 BLAKE2B aac7fa1a1a77be545e0198503a3557beff145ac1eff3615039ba66a994189f6de72f6062d2a6829199cb071bd03a3b23234992a293546178dc59af5bfc77ef74 SHA512 9eef4abcf551f313e508f2c3f1ffdae56142b2aa933942c0e9733d7e80a9d8324edd870d03a225683586a06fbd3a78dda5f95e81aac648e7864dcfc785797225
EBUILD cfn-lint-0.61.4.ebuild 1640 BLAKE2B ab0b276a17eb6e1736a03f89d00a70a55840063177efdb4ca391f399acb5dea04480b4a31bf9bba12c607f35381d95b44dd6e346141d9e7e084eb4d48fe829e7 SHA512 ebc9ee814224010bf27a5e9675de5e1eed72073441da99ef9b8a3f8c17041eb6855d0951d97aa9e7f6f3d5aab758d594cdb3c93d9d990b4dac990e0fb9434a9a
+EBUILD cfn-lint-0.61.5.ebuild 1640 BLAKE2B ab0b276a17eb6e1736a03f89d00a70a55840063177efdb4ca391f399acb5dea04480b4a31bf9bba12c607f35381d95b44dd6e346141d9e7e084eb4d48fe829e7 SHA512 ebc9ee814224010bf27a5e9675de5e1eed72073441da99ef9b8a3f8c17041eb6855d0951d97aa9e7f6f3d5aab758d594cdb3c93d9d990b4dac990e0fb9434a9a
MISC metadata.xml 583 BLAKE2B 9f73e2b92e5cfa2ad59f5c8e5d91bdd3aa9eba3fa722b93b388cffea42020db7e7441bab5749432812934a4514d3e9104e6d897e1d115afa5ed237757bd48c03 SHA512 1866a349855ae4e248498b7aabd6ce4c4e10ea58731df4bfa13500f61dc041da6dbd7420e7d6a78fad46d5cf00bd7ef2d0c4c7d6819a21b3a5031b0d49588a19
diff --git a/dev-python/cfn-lint/cfn-lint-0.61.5.ebuild b/dev-python/cfn-lint/cfn-lint-0.61.5.ebuild
new file mode 100644
index 000000000000..57fd1d8c6029
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.61.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+SRC_URI="
+ https://github.com/aws-cloudformation/cfn-lint/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.47.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema_to_python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/sarif_om-1.0.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_2
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+)
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}