summaryrefslogtreecommitdiff
path: root/dev-python/cfn-lint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-27 12:56:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-27 12:56:47 +0000
commit4482d99f0743195c71b2b03faa8bfbda5501910b (patch)
tree853f042c5e26ca4bce5b091ccc3128b9a763984a /dev-python/cfn-lint
parent9c4ecbcb1ba97e8bfd6dac8c2433fb9fdfee5fe6 (diff)
gentoo auto-resync : 27:01:2024 - 12:56:47
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest2
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.85.0.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 05bda499d7e9..bcea370ef936 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,5 +1,7 @@
DIST cfn-lint-0.83.8.tar.gz 3901954 BLAKE2B 33d728ddf7ae5bcb29fdb8211decd85b72519acd60b80831aafa59d042105af45a3f07e2d6ea9838b80af68f6eb19ba84be562e4a7104c64b68737ede3497b0d SHA512 f520f5e211284197ff3b2c5287cb72384544a273e1fa1d3007e7a3ad85ef1b4bae4ed0c0db609989ea51de29630454d97ba13a8d97ccc06992a7fb0da467e0b7
DIST cfn-lint-0.84.0.tar.gz 3890781 BLAKE2B 160c8f29f2551c0885d784d725e5e7077aaf162b13f8bcbe8f04c2f6dd939bdb22166ebc3fbba6ba71b0ec68356f520ae1968a447a7a24082eb85271c684aa1b SHA512 0e783c6c2fc590ce59526da887a3bdcc2f8c55e6d5d6e11f49df82c72d387a18abbac545b861bf806e829080b7be6da00d948d32769396b6730570ab4bc23f7a
+DIST cfn-lint-0.85.0.tar.gz 3875659 BLAKE2B 64bbd4ba0dc153b78da40588a2d0e9f34feafcf17b7262b84f3c3e0a98ecc6cc7b78152dc829fd2bcb3f3c3fe601fdf217111bd5a11d402a3b70ceda822206f7 SHA512 b7d65fb360e8743f08ec2feb451e6dc6cbda62c0850a954e5beec8d6a2a6bee2be2dddee36f262f571e5e9838deb7237895a3020b951686423315f5914f82d67
EBUILD cfn-lint-0.83.8.ebuild 2065 BLAKE2B 1c74b61135135c68cda92c13305673d9cf690f3ea6882c63fcfe51c0570ed87ce3843670f7c2f085a7a52b34e2b947f931ffdfb1f2ecad6a79fbb575370027cf SHA512 a83f63069afa0ede0760b3c4df18f2e0a045ba5dcbfed2c8486cf19df39eaa431d298e3cce5be92b588ef01dd25f86e5201e41b9d331ba2877b84c790e81727b
EBUILD cfn-lint-0.84.0.ebuild 2068 BLAKE2B c25c0933d27f785f1f98ee0a9040a36e25b369a4e67bcb47bec188bb303a2133755ad081b8fb52a0d86ed3ee59e7a68c8e99cca9b1a76f1d26ece4650be8635a SHA512 dd483335192e786b1d994556b7070d5ae7c8f0e06f3749496c07b763e28c41a3ab310f2a8972c0e39e288878fefca7b98d009a5ef478d77e07a0bb71502229b2
+EBUILD cfn-lint-0.85.0.ebuild 2068 BLAKE2B c25c0933d27f785f1f98ee0a9040a36e25b369a4e67bcb47bec188bb303a2133755ad081b8fb52a0d86ed3ee59e7a68c8e99cca9b1a76f1d26ece4650be8635a SHA512 dd483335192e786b1d994556b7070d5ae7c8f0e06f3749496c07b763e28c41a3ab310f2a8972c0e39e288878fefca7b98d009a5ef478d77e07a0bb71502229b2
MISC metadata.xml 583 BLAKE2B 9f73e2b92e5cfa2ad59f5c8e5d91bdd3aa9eba3fa722b93b388cffea42020db7e7441bab5749432812934a4514d3e9104e6d897e1d115afa5ed237757bd48c03 SHA512 1866a349855ae4e248498b7aabd6ce4c4e10ea58731df4bfa13500f61dc041da6dbd7420e7d6a78fad46d5cf00bd7ef2d0c4c7d6819a21b3a5031b0d49588a19
diff --git a/dev-python/cfn-lint/cfn-lint-0.85.0.ebuild b/dev-python/cfn-lint/cfn-lint-0.85.0.ebuild
new file mode 100644
index 000000000000..237b8f7087d0
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.85.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.83.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/regex-2021.7.1[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}