summaryrefslogtreecommitdiff
path: root/dev-python/cfn-lint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-16 15:36:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-16 15:36:38 +0000
commit39fcd539b9eeb7df75bccad136265b5f001d1a3c (patch)
treefcedf7eec512b29edce8c642c52f834b2e15b4f8 /dev-python/cfn-lint
parentb982051e7c8e12c3810a0d21d30d687b406b3ae5 (diff)
gentoo auto-resync : 16:12:2022 - 15:36:37
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest2
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.72.4.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index a4f9b570c138..7832bf2ab173 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,5 +1,7 @@
DIST cfn-lint-0.71.1.gh.tar.gz 2984397 BLAKE2B faa2164ee0f469f8e9118b82d5c86dee05e5404feb5ae28abd9e4218122677dba09308d5a573c4eaabb8f321932b8de621a39bc20f1c86724dc24fedac7e7a93 SHA512 dee916eaa43eabcc4cf2db7fb08db8875f68292a56aa97d29d0d291da51a828a78b681162b71759ec0dc3d246570dbce8fe33a41ce61c22e6fbf2a4ff15f49ff
DIST cfn-lint-0.72.2.gh.tar.gz 3114298 BLAKE2B 5a426a046d1a0ffb773f9b34c544ccf9f55467de156f3bc0c3324c9877a1f101da69130c39a0d0144d57557c75e9bbcecc41bb1823fe41c00f14874c516c0033 SHA512 2248e2854410ba889180dd20df1f8c1ec70150b8433a7b4d564c6d9a9c7ceaedc81bf051eeaf1906878e57dc395c5e4c08623574cb9f4dced9ea0a8fbe73325d
+DIST cfn-lint-0.72.4.gh.tar.gz 3199849 BLAKE2B b0c81be6e2f21ffbc7ee4ebbfc4994d1b413516dc3a47d11f554278b33ead1d3c3c055b541e25a7401fa911c16998cf3c3c85863d2e0f295c1d3df86b78f8847 SHA512 994f418519e72e1814f2ee38e3e5a42f7e2dc1556cda5cb5632b0e57daadbad57425e14d1eff67ba39f0ca1dd22df22f43277f1b1b3d6b66679cc3526fbeedd0
EBUILD cfn-lint-0.71.1.ebuild 1638 BLAKE2B d6f1eb649359ad720f936be2dcefbd7c0f0106624e1189dd7af84a690255aba1faf6cfe40e441a51560b66b4b49e1d91e02e3a6cf293dfa5b9bd6132f7349922 SHA512 aec08fc4886ee20dfab104e0c9829bd7a19c85d84dec6262a909a138a56b7eb441177c40fed1cdfc0c7f5cba89edabce9a2328135bccf3d1fde0dae3fc7e6a28
EBUILD cfn-lint-0.72.2.ebuild 1640 BLAKE2B 0e316501d527a704dcbd50724505468c906e84e00c9861ae701b176db497b6c67072283627bc1200759429896d58ac6a0007ef4dfd7dd1bc8ee9b4e417eed64d SHA512 2faaaa66c9015dc80c36392a03747515fc42985129d8f9aa02a2a9d14235c60eb803996c923ffb01f2c776b1f20b8ca3e2a931a5aa5f2f1fbf93eb5361eb69ed
+EBUILD cfn-lint-0.72.4.ebuild 1640 BLAKE2B 0e316501d527a704dcbd50724505468c906e84e00c9861ae701b176db497b6c67072283627bc1200759429896d58ac6a0007ef4dfd7dd1bc8ee9b4e417eed64d SHA512 2faaaa66c9015dc80c36392a03747515fc42985129d8f9aa02a2a9d14235c60eb803996c923ffb01f2c776b1f20b8ca3e2a931a5aa5f2f1fbf93eb5361eb69ed
MISC metadata.xml 583 BLAKE2B 9f73e2b92e5cfa2ad59f5c8e5d91bdd3aa9eba3fa722b93b388cffea42020db7e7441bab5749432812934a4514d3e9104e6d897e1d115afa5ed237757bd48c03 SHA512 1866a349855ae4e248498b7aabd6ce4c4e10ea58731df4bfa13500f61dc041da6dbd7420e7d6a78fad46d5cf00bd7ef2d0c4c7d6819a21b3a5031b0d49588a19
diff --git a/dev-python/cfn-lint/cfn-lint-0.72.4.ebuild b/dev-python/cfn-lint/cfn-lint-0.72.4.ebuild
new file mode 100644
index 000000000000..0b3070eb0d84
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.72.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+SRC_URI="
+ https://github.com/aws-cloudformation/cfn-lint/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.55.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema_to_python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/sarif_om-1.0.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_2
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+)
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}