summaryrefslogtreecommitdiff
path: root/dev-python/cfgv/cfgv-3.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-14 00:11:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-14 00:11:33 +0100
commit1013bb04a30c552ec7ff5e3fe97074b0531a024d (patch)
treea94f2330bae429402db01020da9c60782e27af89 /dev-python/cfgv/cfgv-3.4.0.ebuild
parent40c113c340752d507394d37cd6b60abb741daed0 (diff)
gentoo auto-resync : 14:08:2023 - 00:11:33
Diffstat (limited to 'dev-python/cfgv/cfgv-3.4.0.ebuild')
-rw-r--r--dev-python/cfgv/cfgv-3.4.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/cfgv/cfgv-3.4.0.ebuild b/dev-python/cfgv/cfgv-3.4.0.ebuild
new file mode 100644
index 000000000000..8561fd9479b4
--- /dev/null
+++ b/dev-python/cfgv/cfgv-3.4.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Validate configuration and produce human-readable error messages"
+HOMEPAGE="
+ https://github.com/asottile/cfgv/
+ https://pypi.org/project/cfgv/
+"
+SRC_URI="
+ https://github.com/asottile/cfgv/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+distutils_enable_tests pytest