summaryrefslogtreecommitdiff
path: root/dev-python/cffi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /dev-python/cffi
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'dev-python/cffi')
-rw-r--r--dev-python/cffi/Manifest2
-rw-r--r--dev-python/cffi/cffi-1.11.4.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/cffi/Manifest b/dev-python/cffi/Manifest
index 8d3ec134361f..737ab608dde0 100644
--- a/dev-python/cffi/Manifest
+++ b/dev-python/cffi/Manifest
@@ -1,5 +1,7 @@
DIST cffi-1.11.2.tar.gz 435142 BLAKE2B ba90cc377261a75557cef626f1c6b8c0c625c67212b546d42ca56c3360496d01c59984f72d5ce61b1160aa6117b869e567b17df8458de2c88a42dc5e653f6129 SHA512 8ccd8988bb6b4beb760abe5d8cac7cbf65a7dcfad5a535343e5961912751f426fdf6e602a983430e6aa9f56f2f623855b0cfb5ed8e5294a95d122866a4533eda
+DIST cffi-1.11.4.tar.gz 436857 BLAKE2B 46b5d1adf4aca2a75ea02ba01ae934821d0e864accd9c355745a681d11a08ed34c33c473204c78ecb2113b2d59fbc762ca0607ff92f6cd2dc411907844bbdaf3 SHA512 184572ab8c1f7a72f00084c23894efe1691aa20f9e822a3f7184ebbed16e757586ac47e7f1d12dd7b14b4322bf5b88e35465dc3bc8b0caf0dc8e2b626a52615e
DIST cffi-1.9.1.tar.gz 407108 BLAKE2B f95e99cbb7a10aacb714d6ddbe85755e24d4fbdebb9ada0ab87c95b58aa56b364df612fbdfbf6fcc3a9dfff6e96fe5e979ee37b1c6c9b62b6ba8d3a9565def2f SHA512 6e76f181b6b7b760a14ad70338edd104a8b8e2eac5680e336d3868e0bd031a1665608e29a65dc0c56806afb8a8c03811586f151f3acef11e54e60c1bfcf902e3
EBUILD cffi-1.11.2.ebuild 1480 BLAKE2B c23becdeea76e177e8dbe0477e912c530bb681b135b21d589de0572da460954b9af97af8c241ca690d155a9d1926ccbcd1d00d86769cd995929d20cd0b14b2c7 SHA512 53a7ffd66b39c0913db5fb8a1d299964311243282a0adb95b3a909fa1875777d5a4d0fa730805a1f488a157f27083f6221884662ed6e57d6772e752421a62b5c
+EBUILD cffi-1.11.4.ebuild 1492 BLAKE2B efc8cb5c599305bdcf683d2ab18e715f6ec7cd624548b84298e0c2a5f5a47156a13de3584d4d10599e2398a61d5612fd015b3a42b512095943ad3587213990fc SHA512 24f29ff92cda1aac7266dec44fa7092dd39ab0d81fa0fa1af0cfea4af7d7e45369f23ce5bb7c927313665a32034c61cfb9db013356d1d9076719450f168801a7
EBUILD cffi-1.9.1.ebuild 1470 BLAKE2B 9205a47a11f98db74678be1a1db8037bafdac399ccd90a9ec20b347a39ac69ef486b53adfb72e9482bca0922ff06cc4a85d23e251600c9ab34bf18d0b815563d SHA512 54dce8ee5a318e032fe01e6e47682674a7f9c0f5d04f56e96ffd028902d19e2bceecef123cfca68f3c0048ca40193fc49ebaac555ada72847642331d85ccd7c3
MISC metadata.xml 317 BLAKE2B b6416209bd2358c42c2be3bd228238b401bf126919b6e7371d83d7cec8cb55a40f89db562701cc8f3dfa904e225426881b22ff1d3b72085365b5caf9b8c6a403 SHA512 0744ca7b98b2ebe2985bf2a81a337d09be62cfaa51f8380bac52f8d30941e997f09be20e28caf6967226a71369003cf35977790aba56ed0d469cc490cfa089b6
diff --git a/dev-python/cffi/cffi-1.11.4.ebuild b/dev-python/cffi/cffi-1.11.4.ebuild
new file mode 100644
index 000000000000..c8e28a30f4cc
--- /dev/null
+++ b/dev-python/cffi/cffi-1.11.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# DO NOT ADD pypy to PYTHON_COMPAT
+# pypy bundles a modified version of cffi. Use python_gen_cond_dep instead.
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Foreign Function Interface for Python calling C code"
+HOMEPAGE="https://cffi.readthedocs.io/ https://pypi.python.org/pypi/cffi"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="doc test"
+
+RDEPEND="
+ virtual/libffi
+ dev-python/pycparser[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+# Avoid race on _configtest.c (distutils/command/config.py:_gen_temp_sourcefile)
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ einfo "$PYTHONPATH"
+ $PYTHON -c "import _cffi_backend as backend" || die
+ PYTHONPATH="${PYTHONPATH}" \
+ py.test -x -v \
+ --ignore testing/test_zintegration.py \
+ --ignore testing/embedding \
+ c/ testing/ \
+ || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}