summaryrefslogtreecommitdiff
path: root/dev-python/cbor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/cbor
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/cbor')
-rw-r--r--dev-python/cbor/Manifest3
-rw-r--r--dev-python/cbor/cbor-1.0.0.ebuild19
-rw-r--r--dev-python/cbor/metadata.xml28
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/cbor/Manifest b/dev-python/cbor/Manifest
new file mode 100644
index 000000000000..75bb718f0729
--- /dev/null
+++ b/dev-python/cbor/Manifest
@@ -0,0 +1,3 @@
+DIST cbor-1.0.0.tar.gz 20096 BLAKE2B 0e15bc4984155c1046836c94f3025f8dd451aaad438c78de25a739738e6de8d3ff3e737dbaeaace3d837be08e9702a3b7d18d840c0bc5459cd3919159eabd728 SHA512 996b61c7d16cbe8bd7b056d09286a17f3a6a29cb97ef9e5ca1d1bfe8c53393ae3d2b7565c937a283cb78f377af14c070bd663aabbce995dc7e5b9d2f69a6ba73
+EBUILD cbor-1.0.0.ebuild 472 BLAKE2B 7bf26fa2c9deb769490f9fc3c1db52b90d4889eb8493ab28b3827f934ac7fe49d1909917279268ab4830328c505d78d2146868b03fff17d974f750b5f3edcdf0 SHA512 31966bd3a8e5ae94d82dde15c71022c2cdba9a806d452151c8af7417b4923a4d2bae87d2c2e0a48b73085056f8d01df675974d31fcf42bb5ed39521ca5dad779
+MISC metadata.xml 1074 BLAKE2B 7621eefc67c6d29dff5ae32e9237e65d3dcbe4601250cdb524d380c7bff4216b03586ab600c39592f736205f1c9dadc73efcf55ec97e5ff65f126fa2a1893515 SHA512 6ad1e74d0f932664eaa1f635adf78ed6429308e354e195f6bebef74385ab414ffbb1c94739dce3473ad62751241ee3bafc8eb74bce63f431b4e774250e2c7bc8
diff --git a/dev-python/cbor/cbor-1.0.0.ebuild b/dev-python/cbor/cbor-1.0.0.ebuild
new file mode 100644
index 000000000000..c92ca745b035
--- /dev/null
+++ b/dev-python/cbor/cbor-1.0.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="RFC 7049 - Concise Binary Object Representation"
+HOMEPAGE="https://bitbucket.org/bodhisnarkva/cbor https://pypi.org/project/cbor/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 arm x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
diff --git a/dev-python/cbor/metadata.xml b/dev-python/cbor/metadata.xml
new file mode 100644
index 000000000000..a7a1e422560f
--- /dev/null
+++ b/dev-python/cbor/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dolsen@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>bolson@bolson.org</email>
+ <name>Brian Olson</name>
+ </maintainer>
+ <remote-id type="pypi">cbor</remote-id>
+ <remote-id type="bitbucket">bodhisnarkva/cbor</remote-id>
+ </upstream>
+ <longdescription>An implementation of RFC 7049 - Concise Binary Object
+ Representation (CBOR). CBOR is comparable to JSON, has a superset of
+ JSON's ability, but serializes to a binary format which is smaller and
+ faster to generate and parse. The two primary functions are
+ cbor.loads() and cbor.dumps(). This library includes a C implementation
+ which runs 3-5 times faster than the Python standard library's
+ C-accelerated implementanion of JSON. This is also includes a 100%
+ Python implementation.
+ </longdescription>
+</pkgmetadata>