summaryrefslogtreecommitdiff
path: root/dev-python/cbor2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/cbor2
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/cbor2')
-rw-r--r--dev-python/cbor2/Manifest3
-rw-r--r--dev-python/cbor2/cbor2-5.1.0.ebuild30
-rw-r--r--dev-python/cbor2/metadata.xml23
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/cbor2/Manifest b/dev-python/cbor2/Manifest
new file mode 100644
index 000000000000..95b80cfd14eb
--- /dev/null
+++ b/dev-python/cbor2/Manifest
@@ -0,0 +1,3 @@
+DIST cbor2-5.1.0.tar.gz 72328 BLAKE2B 22737f1ce152eb356fc937199ba83e9558b68900f8183ee8acca52312fa56499812d6b26aaaa629b6e2cfacbdfbb72f65cb7fcbe93a010320aff94aec8dc3978 SHA512 0df4f0c5609ae8d73627a64ee1544af88461b2bf829538f23d912138cf47ae8d03193644c7315e2a77318e58fd2bd61c4cb103d94ed0710db0ae5c2cf4df60b7
+EBUILD cbor2-5.1.0.ebuild 673 BLAKE2B b604aebfc3f5e79713b4a914b96af70c714de3144d6d5fe8769b4e2eec70e31a1dec452b1502fc4440d8d80d8b54f73bdc340a036c34148e8566b65247042abb SHA512 4dfa782b3859c53ad176cb4a94c5560abfed5c104c55fd5413b58adcf800848b826a72e67043a5ae23734c4124e48a5a98193f4cbef9672a1e13add43da949f9
+MISC metadata.xml 894 BLAKE2B b6180631eee31ff627a9ec598c98db018c8445bed530477b2c40da412bc61cace8a22073b1b386965a8817c7b25a976b1ab535f31d99279813e4a4ea0a7b5fb5 SHA512 1ab12e51dc2a38646f3a8ff334e5833a0e1673664e9ba26bc8d9f7b0feb9b69d0b32ff232ea363d804483c18a1b23c9cd1a8dd02a18b7f796db80f383ff55c09
diff --git a/dev-python/cbor2/cbor2-5.1.0.ebuild b/dev-python/cbor2/cbor2-5.1.0.ebuild
new file mode 100644
index 000000000000..0a40842019e6
--- /dev/null
+++ b/dev-python/cbor2/cbor2-5.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure Python CBOR (de)serializer with extensive tag support"
+HOMEPAGE="https://github.com/agronholm/cbor2 https://pypi.org/project/cbor2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+DEPENDS="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )
+"
+
+RDEPEND="${DEPEND}"
+
+distutils_enable_tests pytest
diff --git a/dev-python/cbor2/metadata.xml b/dev-python/cbor2/metadata.xml
new file mode 100644
index 000000000000..77d7b556b447
--- /dev/null
+++ b/dev-python/cbor2/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dolsen@gentoo.org</email>
+ <name>Brian Dolbec</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>bolson@bolson.org</email>
+ <name>Brian Olson</name>
+ </maintainer>
+ <remote-id type="pypi">cbor</remote-id>
+ <remote-id type="bitbucket">bodhisnarkva/cbor</remote-id>
+ </upstream>
+ <longdescription>This library provides encoding and decoding for the
+Concise Binary Object Representation (CBOR) (RFC 7049) serialization format.
+It is implemented in pure python with an optional C backend and is compatible
+with versions 2.7 through to 3.8. On cPython>=3.3 cbor2 can use a built in C
+module for performance similar to how pickle wraps the _pickle C module in the
+Python Standard Library.
+ </longdescription>
+</pkgmetadata>