summaryrefslogtreecommitdiff
path: root/dev-python/cbor/cbor-1.0.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/cbor/cbor-1.0.0-r1.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/cbor/cbor-1.0.0-r1.ebuild')
-rw-r--r--dev-python/cbor/cbor-1.0.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/cbor/cbor-1.0.0-r1.ebuild b/dev-python/cbor/cbor-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..28ec5ba34fcd
--- /dev/null
+++ b/dev-python/cbor/cbor-1.0.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+EGIT_COMMIT="b3af679e7cf3e12d50acb83c3c591fc5db9a658d"
+DESCRIPTION="RFC 7049 - Concise Binary Object Representation"
+HOMEPAGE="https://github.com/brianolson/cbor_py
+ https://pypi.org/project/cbor/"
+SRC_URI="
+ https://github.com/brianolson/cbor_py/archive/${EGIT_COMMIT}.tar.gz
+ -> ${P}.gh.tar.gz"
+S=${WORKDIR}/cbor_py-${EGIT_COMMIT}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 x86 ~amd64-linux ~x86-linux"
+
+# upstream PR: https://github.com/brianolson/cbor_py/pull/19
+# upstream PR: https://github.com/brianolson/cbor_py/pull/11
+PATCHES=(
+ "${FILESDIR}/cbor-1.0.0.zero-length-bytes.patch"
+ "${FILESDIR}/cbor-1.0.0.Fix-broken-test_sortkeys.patch"
+ "${FILESDIR}/cbor-1.0.0.Replace-deprecated-logger.warn.patch"
+)
+
+python_test() {
+ distutils_install_for_testing
+ PYTHONPATH="${BUILD_DIR}/lib" \
+ "${PYTHON:-python}" cbor/tests/test_cbor.py || die "Testsuite failed under ${EPYTHON}"
+ PYTHONPATH="${BUILD_DIR}/lib" \
+ "${PYTHON:-python}" cbor/tests/test_objects.py || die "Testsuite failed under ${EPYTHON}"
+ PYTHONPATH="${BUILD_DIR}/lib" \
+ "${PYTHON:-python}" cbor/tests/test_usage.py || die "Testsuite failed under ${EPYTHON}"
+ PYTHONPATH="${BUILD_DIR}/lib" \
+ "${PYTHON:-python}" cbor/tests/test_vectors.py || die "Testsuite failed under ${EPYTHON}"
+}