summaryrefslogtreecommitdiff
path: root/dev-python/canonicaljson/canonicaljson-1.6.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-05 15:18:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-05 15:18:09 +0000
commitc66fa6cf106b825bcc6f1beeff9486ff08232cbe (patch)
treed5147c1533df62427a098f373049d1ec15a7fbc3 /dev-python/canonicaljson/canonicaljson-1.6.4.ebuild
parent54c42eb42df420f52e032fcba7727c326ef01094 (diff)
gentoo auto-resync : 05:11:2022 - 15:18:09
Diffstat (limited to 'dev-python/canonicaljson/canonicaljson-1.6.4.ebuild')
-rw-r--r--dev-python/canonicaljson/canonicaljson-1.6.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/canonicaljson/canonicaljson-1.6.4.ebuild b/dev-python/canonicaljson/canonicaljson-1.6.4.ebuild
new file mode 100644
index 000000000000..fdad35dc04ab
--- /dev/null
+++ b/dev-python/canonicaljson/canonicaljson-1.6.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Canonical JSON"
+HOMEPAGE="
+ https://github.com/matrix-org/python-canonicaljson/
+ https://pypi.org/project/canonicaljson/
+"
+SRC_URI="
+ https://github.com/matrix-org/python-canonicaljson/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+S="${WORKDIR}/python-${P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+RDEPEND="
+ dev-python/simplejson[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest