summaryrefslogtreecommitdiff
path: root/dev-python/caldav/caldav-1.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-19 08:13:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-19 08:13:24 +0000
commitfd089c26c06476b291a5255011ee378561c2615d (patch)
tree399fe09e6963d1ae925dd682eabcc3fab873daf7 /dev-python/caldav/caldav-1.1.1.ebuild
parent1aa99ecc93a15a428a88197dd05d97bcd33102b7 (diff)
gentoo auto-resync : 19:02:2023 - 08:13:24
Diffstat (limited to 'dev-python/caldav/caldav-1.1.1.ebuild')
-rw-r--r--dev-python/caldav/caldav-1.1.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/caldav/caldav-1.1.1.ebuild b/dev-python/caldav/caldav-1.1.1.ebuild
new file mode 100644
index 000000000000..8f1601942874
--- /dev/null
+++ b/dev-python/caldav/caldav-1.1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="CalDAV (RFC4791) client library for Python"
+HOMEPAGE="
+ https://github.com/python-caldav/caldav/
+ https://pypi.org/project/caldav/
+"
+SRC_URI="
+ https://github.com/python-caldav/caldav/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="|| ( GPL-3 Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/vobject[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/icalendar[${PYTHON_USEDEP}]
+ dev-python/recurring-ical-events[${PYTHON_USEDEP}]
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ www-apps/radicale[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest