summaryrefslogtreecommitdiff
path: root/dev-python/cachetools/cachetools-5.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-23 12:55:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-23 12:55:08 +0000
commit47bb4031ea0e98a9423d423f2181c0e3d06f256b (patch)
tree6a54fb70ac916b8ae725d002ac4a71386c8b6e2f /dev-python/cachetools/cachetools-5.3.0.ebuild
parent9a1d1c6b10a4640cea10e7040ed173cf593f4cab (diff)
gentoo auto-resync : 23:01:2023 - 12:55:07
Diffstat (limited to 'dev-python/cachetools/cachetools-5.3.0.ebuild')
-rw-r--r--dev-python/cachetools/cachetools-5.3.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/cachetools/cachetools-5.3.0.ebuild b/dev-python/cachetools/cachetools-5.3.0.ebuild
new file mode 100644
index 000000000000..b2389ae9952f
--- /dev/null
+++ b/dev-python/cachetools/cachetools-5.3.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Extensible memoizing collections and decorators"
+HOMEPAGE="
+ https://github.com/tkem/cachetools/
+ https://pypi.org/project/cachetools/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+distutils_enable_tests pytest