summaryrefslogtreecommitdiff
path: root/dev-python/build
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/build
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/build')
-rw-r--r--dev-python/build/Manifest3
-rw-r--r--dev-python/build/build-0.7.0-r1.ebuild65
-rw-r--r--dev-python/build/build-0.7.0.ebuild2
3 files changed, 68 insertions, 2 deletions
diff --git a/dev-python/build/Manifest b/dev-python/build/Manifest
index 05778aff4c6a..0559be9f0b57 100644
--- a/dev-python/build/Manifest
+++ b/dev-python/build/Manifest
@@ -1,3 +1,4 @@
DIST build-0.7.0.gh.tar.gz 37127 BLAKE2B b06ba16c154087046bd5efddb5fd6f60dad9ee79a204a0c1124fb4885d3692bcf4bd88b75c9665ade3f8457e12742d32e3cef40a0ffb5a894b049a6e942c09e3 SHA512 fd8410dc91333ba94c5141dd78f8052b66f947839752a5d0f401630f6bceed5be2e1f45eceaa2a98908c0e3ddb88a00e3ccca341a3890fa99202bc560ab6ff42
-EBUILD build-0.7.0.ebuild 1720 BLAKE2B b47a40feb4b05e9eb9680fb7133d0a4862cb5e5d14cd3018aae9125261c1acaa393b5a92c30bfefa430f60141483cfe0263e8087bf0c9a28675a86fbbe1b00e4 SHA512 9152d3e0436c69c97001305d769cca6eb1fa65f62527d5c6596fca318cb17d2f73e444b3fcf60e465e28a23133ee16476475b056d69227db0962b726e02a4498
+EBUILD build-0.7.0-r1.ebuild 1954 BLAKE2B 58a291960cfe8aa133c3817c87f2de2fc2e08057bd34bbafc8485dadc55e063c1b83aa3461bdb8751c39b3bf2b601b130409a3cfc37e3ef68a6b04c6009d2fcf SHA512 87766068ccf69c4c4f6028c69ea1c79ed1243eaf73de570ad9ec9f852e34b76156a85d6c8ff2399cf6366e92e553737f13a2717d75d420fe4a73d529a174634c
+EBUILD build-0.7.0.ebuild 1727 BLAKE2B d8cdba74a33db197a2901a906ed81f891eaaf9c79706395fc5a8955528681ff3e77be3ea223c5f492511feaf6319406440b10b99db2f1927e3af2e7043c647b2 SHA512 f713734516587727f3874ccb6d0d1042cd84fde5adc0989963ca70858a819785fcc9a4ee3b84c3536ad10a969d4a2606b58ee714c2e3bf915f792276c71942b7
MISC metadata.xml 361 BLAKE2B 1c46e1d83bec4a8aaedd932af700865009735ff75e3af63ef7c08f7c00883d5f658f86aec981cd48c8ef0ab0a287250a3a4fdfad42fb434f6c06d9f33f72f7d6 SHA512 89c86db40833c86e25f387c5bfa8952b62e983714be85af1e8ca2a6ef8a402b94cc32dfc18cda8d8850736aaabdb46c153743af9bcb027e86b2c1f085f6f2369
diff --git a/dev-python/build/build-0.7.0-r1.ebuild b/dev-python/build/build-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..049661a8726c
--- /dev/null
+++ b/dev-python/build/build-0.7.0-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="A simple, correct PEP517 package builder"
+HOMEPAGE="
+ https://pypi.org/project/build/
+ https://github.com/pypa/build/
+"
+SRC_URI="
+ https://github.com/pypa/build/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-19.0[${PYTHON_USEDEP}]
+ >=dev-python/pep517-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/filelock-3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-rerunfailures-9.1[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-56.0.0[${PYTHON_USEDEP}]
+ >=dev-python/wheel-0.36.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # broken by the presence of flit_core
+ tests/test_util.py::test_wheel_metadata_isolation
+ # broken by the presence of virtualenv (it changes the error
+ # messages, sic!)
+ tests/test_env.py::test_isolated_env_log
+ tests/test_main.py::test_output_env_subprocess_error
+ 'tests/test_main.py::test_output[via-sdist-isolation]'
+ 'tests/test_main.py::test_output[wheel-direct-isolation]'
+ # Internet
+ tests/test_main.py::test_build_package
+ tests/test_main.py::test_build_package_via_sdist
+ 'tests/test_util.py::test_wheel_metadata[True]'
+ tests/test_util.py::test_with_get_requires
+ )
+ [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
+ # fixed in git but the patch is large-ish
+ tests/test_env.py::test_executable_missing_post_creation
+ )
+
+ epytest -p no:flaky -n "$(makeopts_jobs)" \
+ -W"ignore:path is deprecated.:DeprecationWarning"
+}
diff --git a/dev-python/build/build-0.7.0.ebuild b/dev-python/build/build-0.7.0.ebuild
index 5b4dfa4ea92a..8555e5d4feb2 100644
--- a/dev-python/build/build-0.7.0.ebuild
+++ b/dev-python/build/build-0.7.0.ebuild
@@ -15,7 +15,7 @@ SRC_URI="
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
RDEPEND="
>=dev-python/packaging-19.0[${PYTHON_USEDEP}]