summaryrefslogtreecommitdiff
path: root/dev-python/build
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-16 20:05:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-16 20:05:28 +0000
commit41e056b08e4c5c8d6e78407a5586afa52867fd5f (patch)
tree5c065bb2a5c9eb0386762c79e910ad74512def88 /dev-python/build
parentb18dbdc69b2be6f0ac0db668b0bc57fb6f766afc (diff)
gentoo auto-resync : 16:02:2023 - 20:05:28
Diffstat (limited to 'dev-python/build')
-rw-r--r--dev-python/build/Manifest2
-rw-r--r--dev-python/build/build-0.9.0.ebuild68
2 files changed, 0 insertions, 70 deletions
diff --git a/dev-python/build/Manifest b/dev-python/build/Manifest
index 3fbe45c4f6b8..4ed4bf13281a 100644
--- a/dev-python/build/Manifest
+++ b/dev-python/build/Manifest
@@ -1,5 +1,3 @@
DIST build-0.10.0.gh.tar.gz 41509 BLAKE2B 0b1967af6fd0e47e8de5a6efcab879a37231b399965c4b52d9f952ed4fd64e9606b40f8e34ca18fb634ac5b42e3fa63995e6da292b10424f5ea0bd9fd49a46ca SHA512 e7ab783cc2b228e49c3dd15be7e25150924f26611994367b145cc2d43d7f89597c018cd4ca5cd8b31280d965421d314c80e4b97cf3e00f6cf73d80a3b081e7d1
-DIST build-0.9.0.gh.tar.gz 41012 BLAKE2B 764338ffab3b6ede66542195271b1b07d1cff71685ae88bcef8042ce0a93a3a95a80a8a2273ac6a1534d8416410c8af77fdd3fe52fdacb47b8a56a9857ba60a2 SHA512 d6ef229c8f3b348cc939af6bd9a0a521a25c3a5702a95da8ee36d7a1ad3f3e22e10b5c96495ff08a1328ab73f03feebc64e89ce165862cb295eff4360c79d642
EBUILD build-0.10.0.ebuild 1940 BLAKE2B 9104f2e9a030356e99fca90736ea8968af880af8f634c060d9aba53682c9a1f0d8538d2398a1ddd07bb73ae4c6b5304f314f15acc8377eb39e2340723ccee6d4 SHA512 3ea72c751c18ff42b49a1a0958f80c1c953506af3e045682e8964aaea54150edc3852c6c9a7552a2efcd469ad158cb79b0ff04f41412fe03c770f8e6a641a7ef
-EBUILD build-0.9.0.ebuild 2106 BLAKE2B eb94af6366a3fb141821b97fabede49935f9ed89b51bf731079058b6e46b27c84df6f3ce25b9e4e6ac3a1cdead01a8d582fe628f0ed760e16314442214dca09c SHA512 6af34f93bb8c18b8b7ab66d8d6701cef6732e035dced2d74e3df4ab8e2bdcacd31f5dc5691799c0e819d94a652984181395b7fd4a07b778f7a4a6ac790128947
MISC metadata.xml 361 BLAKE2B 1c46e1d83bec4a8aaedd932af700865009735ff75e3af63ef7c08f7c00883d5f658f86aec981cd48c8ef0ab0a287250a3a4fdfad42fb434f6c06d9f33f72f7d6 SHA512 89c86db40833c86e25f387c5bfa8952b62e983714be85af1e8ca2a6ef8a402b94cc32dfc18cda8d8850736aaabdb46c153743af9bcb027e86b2c1f085f6f2369
diff --git a/dev-python/build/build-0.9.0.ebuild b/dev-python/build/build-0.9.0.ebuild
deleted file mode 100644
index 42499f2e7590..000000000000
--- a/dev-python/build/build-0.9.0.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1 multiprocessing
-
-DESCRIPTION="A simple, correct PEP517 package builder"
-HOMEPAGE="
- https://pypi.org/project/build/
- https://github.com/pypa/build/
-"
-SRC_URI="
- https://github.com/pypa/build/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/packaging-19.0[${PYTHON_USEDEP}]
- >=dev-python/pep517-0.9.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-1.0.0[${PYTHON_USEDEP}]
- ' 3.8 3.9 3.10)
-"
-BDEPEND="
- test? (
- >=dev-python/filelock-3[${PYTHON_USEDEP}]
- >=dev-python/pytest-mock-2[${PYTHON_USEDEP}]
- >=dev-python/pytest-rerunfailures-9.1[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- >=dev-python/setuptools-56.0.0[${PYTHON_USEDEP}]
- >=dev-python/wheel-0.36.0[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # broken by the presence of flit_core
- tests/test_util.py::test_wheel_metadata_isolation
- # broken by the presence of virtualenv (it changes the error
- # messages, sic!)
- tests/test_env.py::test_isolated_env_log
- tests/test_main.py::test_output_env_subprocess_error
- 'tests/test_main.py::test_output[via-sdist-isolation]'
- 'tests/test_main.py::test_output[wheel-direct-isolation]'
- # Internet
- tests/test_main.py::test_build_package
- tests/test_main.py::test_build_package_via_sdist
- tests/test_self_packaging.py::test_build_sdist
- tests/test_self_packaging.py::test_build_wheel
- 'tests/test_util.py::test_wheel_metadata[True]'
- tests/test_util.py::test_with_get_requires
- # we don't really have to test that fallback
- # (requires dev-python/toml that we'd like to lastrite eventually)
- tests/test_projectbuilder.py::test_toml_instead_of_tomli
- )
-
- epytest -p no:flaky -n "$(makeopts_jobs)" \
- -W"ignore:path is deprecated.:DeprecationWarning"
-}