summaryrefslogtreecommitdiff
path: root/dev-python/bpython/bpython-0.24.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-18 17:57:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-18 17:57:26 +0000
commit220240f060e150ba4c4bb2d0f2a07f7c8f9de480 (patch)
treed6e25a202744ce994d341fab9d94c64053830068 /dev-python/bpython/bpython-0.24.ebuild
parent95b557bc48bb734c288bac87dcfe98b8ae3d1cdb (diff)
gentoo auto-resync : 18:01:2023 - 17:57:26
Diffstat (limited to 'dev-python/bpython/bpython-0.24.ebuild')
-rw-r--r--dev-python/bpython/bpython-0.24.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/bpython/bpython-0.24.ebuild b/dev-python/bpython/bpython-0.24.ebuild
new file mode 100644
index 000000000000..60873f7c0ec7
--- /dev/null
+++ b/dev-python/bpython/bpython-0.24.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Syntax highlighting and autocompletion for the Python interpreter"
+HOMEPAGE="
+ https://www.bpython-interpreter.org/
+ https://github.com/bpython/bpython/
+ https://pypi.org/project/bpython/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="clipboard +jedi watch"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/curtsies-0.4.0[${PYTHON_USEDEP}]
+ dev-python/cwcwidth[${PYTHON_USEDEP}]
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ clipboard? ( dev-python/pyperclip[${PYTHON_USEDEP}] )
+ jedi? ( dev-python/jedi[${PYTHON_USEDEP}] )
+ watch? ( dev-python/watchdog[${PYTHON_USEDEP}] )
+"
+# sphinx is used implicitly to build manpages
+BDEPEND="dev-python/wheel[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+DOCS=( AUTHORS.rst CHANGELOG.rst )
+
+distutils_enable_sphinx doc/sphinx/source --no-autodoc
+distutils_enable_tests unittest