summaryrefslogtreecommitdiff
path: root/dev-python/bottle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
commit53cba99042fa967e2a93da9f8db806fe2d035543 (patch)
tree9780d3b87dfc6bdebc6b7b7d15af1ecb813c6853 /dev-python/bottle
parent71deace00d1a2b091313fe137ab7092418c6f87c (diff)
gentoo resync : 17.02.2020
Diffstat (limited to 'dev-python/bottle')
-rw-r--r--dev-python/bottle/Manifest2
-rw-r--r--dev-python/bottle/bottle-0.12.16.ebuild53
2 files changed, 0 insertions, 55 deletions
diff --git a/dev-python/bottle/Manifest b/dev-python/bottle/Manifest
index a6b3d14820e2..e72a3c28c2c0 100644
--- a/dev-python/bottle/Manifest
+++ b/dev-python/bottle/Manifest
@@ -1,6 +1,4 @@
AUX bottle-0.12.8-py3.5-backport.patch 1720 BLAKE2B 63081eee3765d060d7381a0eeca97fde17367273b0308449678301f0d2ed9357c90881aeeff31c6a26920ff256b76b0567a74628499fb4d9f2325bc75de6a2e8 SHA512 10f8b95d77d35db582be9bb937ca0c52050c22faa191f373b34039c6ddec24a8e71ce26f6bc9c3f3af7973670343b2f3131c02ed626e3d161a636f8c9e4cdd2b
-DIST bottle-0.12.16.tar.gz 72248 BLAKE2B 21b5bc376648baec74577ac5b57fcacc58899babe07a034a436d5e2bde75a9e2e48b2569c5caf1478e77790c5fa327114ab9b084f014cc1ba97637d9ddfec659 SHA512 3c167f95902522c8f264e8478403da8e9b8cd84594318c4a773d38b7548b5ba95c99ef922033f6885cdc044b31f9c2e2f7ed263886637ce2a048e99c0c6e1403
DIST bottle-0.12.18.tar.gz 71557 BLAKE2B a34cc1ab9a2a8505b7fda8bbddbae30b4e6c4829cae53f0f886237a21fdfa7f2b2463b216d7a16464539f41bdce4c1dabb5cc66027b8fdd19b10e9a78a3cdbb5 SHA512 db8a341cd80d755205518bb9eac5b79dca9e541ab3ad9d9d57f891d895f7df75a8facd16b068cbdf7c4f884f35e384449f4cbd565a43e9c5d000d3a9f5b7dcb0
-EBUILD bottle-0.12.16.ebuild 1477 BLAKE2B 298e895147ca927d982c649109d3f40c515f11e81fa3367b38dfabb4b8263d884e4b83103999fc204da51b060aebad10a744350def2639db8103db95dadc2c90 SHA512 7c6cecc35d259c77fa1037094300119c0845dfd62307c7e0290d908eae6173f45a5daf4c85d78089102b2fffeae6c5af3c1b2a158657d897d749b4b77636fb38
EBUILD bottle-0.12.18.ebuild 1394 BLAKE2B cfc813b8464288e250b5d424d660c8b4fdb64d49068a9b7b294a6c099959bd99ee6867822caa9fe5b6a0d7809f7576048babb2abad1ccb7148138ed9e6b1bffa SHA512 85aed82838651e5d381829f92662e2428dae1f11d3fefbbc9b1a28f8dd0c054058fea133bdf33156034e51253f6260c517113148b7ac9588ebc5a34516b42257
MISC metadata.xml 319 BLAKE2B 29a2c856ee0a0af9214a5cec842b697fcb095d2bcf4702225b2e81d4f715967c29a383da78c43ac60d4464e27e651e81f1b085684b0b6f39925a6df7c36a54c4 SHA512 2ff50f032ea6042a32a7d391906ff95d00115367770423874aa6ee638b1db03fc0b7fabc484e1ecc002eff1e5abf5d45075463b76b7d512535d4820c46b56251
diff --git a/dev-python/bottle/bottle-0.12.16.ebuild b/dev-python/bottle/bottle-0.12.16.ebuild
deleted file mode 100644
index 41250b4a6f30..000000000000
--- a/dev-python/bottle/bottle-0.12.16.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="A fast and simple micro-framework for small web-applications"
-HOMEPAGE="https://pypi.org/project/bottle/ https://bottlepy.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- $(python_gen_cond_dep '
- dev-python/mako[${PYTHON_USEDEP}]
- ' 'python*')
- )"
-RDEPEND=""
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.12.8-py3.5-backport.patch
-)
-
-python_prepare_all() {
- sed -i -e '/scripts/d' setup.py || die
-
- # Remove test file requring connection to network
- rm test/test_server.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # A few odd fails in the suite under pypy
- # https://github.com/bottlepy/bottle/issues/714
- "${EPYTHON}" test/testall.py || die "tests failed under ${EPYTHON}"
-}
-
-pkg_postinst() {
- optfeature "Templating support" dev-python/mako
- elog "Due to problems with bottle.py being in /usr/bin (see bug #474874)"
- elog "we do as most other distros and do not install the script anymore."
- elog "If you do want/have to call it directly rather than through your app,"
- elog "please use the following instead:"
- elog ' `python -m bottle`'
-}