summaryrefslogtreecommitdiff
path: root/dev-python/bottle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/bottle
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/bottle')
-rw-r--r--dev-python/bottle/Manifest6
-rw-r--r--dev-python/bottle/bottle-0.12.12.ebuild48
-rw-r--r--dev-python/bottle/bottle-0.12.13.ebuild48
-rw-r--r--dev-python/bottle/files/bottle-0.12.8-py3.5-backport.patch36
-rw-r--r--dev-python/bottle/metadata.xml11
5 files changed, 149 insertions, 0 deletions
diff --git a/dev-python/bottle/Manifest b/dev-python/bottle/Manifest
new file mode 100644
index 000000000000..b32cf4c6eaa3
--- /dev/null
+++ b/dev-python/bottle/Manifest
@@ -0,0 +1,6 @@
+AUX bottle-0.12.8-py3.5-backport.patch 1720 BLAKE2B 63081eee3765d060d7381a0eeca97fde17367273b0308449678301f0d2ed9357c90881aeeff31c6a26920ff256b76b0567a74628499fb4d9f2325bc75de6a2e8 SHA512 10f8b95d77d35db582be9bb937ca0c52050c22faa191f373b34039c6ddec24a8e71ce26f6bc9c3f3af7973670343b2f3131c02ed626e3d161a636f8c9e4cdd2b
+DIST bottle-0.12.12.tar.gz 71554 BLAKE2B 4b0d0d77c5ebaddcafd44e16a052535ded566245324d39e97a39dd20a193360487f9489e8e89471dd92ca35d6c5b2e8cbe1572a958db31b69d32d3e32f1b6403 SHA512 cdba3859129680f08b8c641708fd884ccf46d404786cbf48435d752fece998a446f49799e4e05e979b967843866f3e966a35a6cac7aed3270df55fae508bae31
+DIST bottle-0.12.13.tar.gz 70870 BLAKE2B d8bdef473181ce1cf6c0d1ea3537c407e68d23c1c44ca33e26c647d3b3783040d466b594c56c10cdd007d23bdf1708412d3e3ff108effa9e8a92e1b22f7a6c69 SHA512 86d106eb08e0b736a85aa69871f2d1e23c1d6f71948b85718daf131002c53c000e092ffdfe5b36c60460473467a2ca2b5af19767344689ffe638245e6859a80b
+EBUILD bottle-0.12.12.ebuild 1436 BLAKE2B 1f9e88d48d449c2754dbc0fd53910ed082e60ec8d73b0ed07e2c1562a9149cf331b72193e9a6803247181460c1ed4305b7af52278603df6c6e6cd414501bd38d SHA512 bfa08b0c9e6826f11e2a3d4818205d3ad1a193cb3838eb777e2e397c69ba4f3763da3b71233d091b347329ba95673d2d8ba2f7105cafa8c712cf1124a2ea951e
+EBUILD bottle-0.12.13.ebuild 1457 BLAKE2B 0898b64962ed5aa1594644ccf9f3f0b32ce830c9f21c830f239f8dda3a19f7d3c6cd028651179ff8a0308d90733ae992617757e981cff9d69d8eededb7798a08 SHA512 542bae4260e75b1ca1953f0c2fed718837ae6dbc35a3a77f928abf7e5cbffb5f58e81f00ec293c1d4ab64c5a0888ff3405adad578141f658e1aec2f4a4ab89eb
+MISC metadata.xml 319 BLAKE2B 29a2c856ee0a0af9214a5cec842b697fcb095d2bcf4702225b2e81d4f715967c29a383da78c43ac60d4464e27e651e81f1b085684b0b6f39925a6df7c36a54c4 SHA512 2ff50f032ea6042a32a7d391906ff95d00115367770423874aa6ee638b1db03fc0b7fabc484e1ecc002eff1e5abf5d45075463b76b7d512535d4820c46b56251
diff --git a/dev-python/bottle/bottle-0.12.12.ebuild b/dev-python/bottle/bottle-0.12.12.ebuild
new file mode 100644
index 000000000000..17fb9272a22b
--- /dev/null
+++ b/dev-python/bottle/bottle-0.12.12.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A fast and simple micro-framework for small web-applications"
+HOMEPAGE="https://pypi.org/project/bottle/ http://bottlepy.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mako[$(python_gen_usedep 'python*')] )"
+RDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.12.8-py3.5-backport.patch
+)
+
+python_prepare_all() {
+ sed -i -e '/scripts/d' setup.py || die
+
+ # Remove test file requring connection to network
+ rm test/test_server.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # A few odd fails in the suite under pypy
+ # https://github.com/bottlepy/bottle/issues/714
+ "${PYTHON}" test/testall.py || die "tests failed under ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "Templating support" dev-python/mako
+ elog "Due to problems with bottle.py being in /usr/bin (see bug #474874)"
+ elog "we do as most other distros and do not install the script anymore."
+ elog "If you do want/have to call it directly rather than through your app,"
+ elog "please use the following instead:"
+ elog ' `python -m bottle`'
+}
diff --git a/dev-python/bottle/bottle-0.12.13.ebuild b/dev-python/bottle/bottle-0.12.13.ebuild
new file mode 100644
index 000000000000..b75ec9750ab3
--- /dev/null
+++ b/dev-python/bottle/bottle-0.12.13.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A fast and simple micro-framework for small web-applications"
+HOMEPAGE="https://pypi.org/project/bottle/ http://bottlepy.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mako[$(python_gen_usedep 'python*')] )"
+RDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.12.8-py3.5-backport.patch
+)
+
+python_prepare_all() {
+ sed -i -e '/scripts/d' setup.py || die
+
+ # Remove test file requring connection to network
+ rm test/test_server.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # A few odd fails in the suite under pypy
+ # https://github.com/bottlepy/bottle/issues/714
+ "${PYTHON}" test/testall.py || die "tests failed under ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "Templating support" dev-python/mako
+ elog "Due to problems with bottle.py being in /usr/bin (see bug #474874)"
+ elog "we do as most other distros and do not install the script anymore."
+ elog "If you do want/have to call it directly rather than through your app,"
+ elog "please use the following instead:"
+ elog ' `python -m bottle`'
+}
diff --git a/dev-python/bottle/files/bottle-0.12.8-py3.5-backport.patch b/dev-python/bottle/files/bottle-0.12.8-py3.5-backport.patch
new file mode 100644
index 000000000000..86e1ac04bc41
--- /dev/null
+++ b/dev-python/bottle/files/bottle-0.12.8-py3.5-backport.patch
@@ -0,0 +1,36 @@
+ test/test_environ.py | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/test/test_environ.py b/test/test_environ.py
+old mode 100755
+new mode 100644
+index 2b8079b..2feebe3
+--- a/test/test_environ.py
++++ b/test/test_environ.py
+@@ -592,7 +592,7 @@ class TestResponse(unittest.TestCase):
+ r.set_cookie('name2', 'value', max_age=datetime.timedelta(days=1))
+ cookies = sorted([value for name, value in r.headerlist
+ if name.title() == 'Set-Cookie'])
+- self.assertEqual(cookies[0], 'name1=value; Max-Age=5')
++ self.assertEqual(cookies[0].lower(), 'name1=value; max-age=5')
+ self.assertEqual(cookies[1], 'name2=value; Max-Age=86400')
+
+ def test_set_cookie_expires(self):
+@@ -602,7 +602,7 @@ class TestResponse(unittest.TestCase):
+ r.set_cookie('name2', 'value', expires=datetime.datetime(1970,1,1,0,0,43))
+ cookies = sorted([value for name, value in r.headerlist
+ if name.title() == 'Set-Cookie'])
+- self.assertEqual(cookies[0], 'name1=value; expires=Thu, 01 Jan 1970 00:00:42 GMT')
++ self.assertEqual(cookies[0].lower(), 'name1=value; expires=thu, 01 jan 1970 00:00:42 gmt')
+ self.assertEqual(cookies[1], 'name2=value; expires=Thu, 01 Jan 1970 00:00:43 GMT')
+
+ def test_delete_cookie(self):
+@@ -611,7 +611,7 @@ class TestResponse(unittest.TestCase):
+ response.delete_cookie('name')
+ cookies = [value for name, value in response.headerlist
+ if name.title() == 'Set-Cookie']
+- self.assertTrue('name=;' in cookies[0])
++ self.assertTrue('Max-Age=-1' in cookies[0])
+
+ def test_set_header(self):
+ response = BaseResponse()
diff --git a/dev-python/bottle/metadata.xml b/dev-python/bottle/metadata.xml
new file mode 100644
index 000000000000..0701f0aad2af
--- /dev/null
+++ b/dev-python/bottle/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">bottle</remote-id>
+ </upstream>
+</pkgmetadata>