summaryrefslogtreecommitdiff
path: root/dev-python/boto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-python/boto
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-python/boto')
-rw-r--r--dev-python/boto/Manifest3
-rw-r--r--dev-python/boto/boto-2.49.0-r2.ebuild30
-rw-r--r--dev-python/boto/files/boto-2.49.0-py38.patch54
3 files changed, 73 insertions, 14 deletions
diff --git a/dev-python/boto/Manifest b/dev-python/boto/Manifest
index 572709726ccc..8ab198480208 100644
--- a/dev-python/boto/Manifest
+++ b/dev-python/boto/Manifest
@@ -1,5 +1,6 @@
+AUX boto-2.49.0-py38.patch 2061 BLAKE2B a17cc48925216f333a12631051f177c9d91199eddcb5dd08c22a3c8381af743b0aeeb7cd5642bb030e951596ee98477abf1e7507a4bfabc9d36706e7809bf031 SHA512 ba42dee03c39cf238c6cb1864500f5d6c0fabcc395021cba8745c3e4fc4e59828eb7f461d5251367d37c4e0709162117e97aeabc08f941fe07c65f6b179244d8
AUX boto-try-to-add-SNI-support-v2.patch 4329 BLAKE2B 3be0a3a88bc252bf8cbf316d3198b58ca86ee61e991400ce1e27854433bcf3709718593c58ffc2e2ad16fa41630a54670a4b7d42efde572073adf5f5f95994e2 SHA512 48b1fa089138a22ca9749fe82a1d92abf7570edf87a6ffc48f9b2389baed8982092afc2cbf1e35bf0661f185e96ba2b2b6d21cb2c553d6d884e800805f013a9a
DIST boto-2.49.0.tar.gz 1478498 BLAKE2B 6a897ea162f5f4bd34a2d488a3e3897f7f2f5b8707dd0922c01b6a0b90ea577223bf3e588b6685bda1f2bc0e92af426711fcba67a70377183465a530065c6c84 SHA512 2175cf30cd25bbc05812e83e5ade7668c3e21b1bb09aa1b43f0f0ac7d6967a646394fb52c9be673ebb65618c5b33a52d6f31f6da702f5cd1d6c9a18169476dd4
-EBUILD boto-2.49.0-r2.ebuild 883 BLAKE2B 128c3d8a978a9249a578bc2637fa0abe25ade76fe55dfe3e7c595df5e9ab9d4a172dff3d5059e02c96d1717bee75ab7f1f419b0047be207aec27a96f58e7aa48 SHA512 ddc5609597677dba4b882260a171160a93c9a9776758c6b9dd789ecbdb6fe2a643fa82e7871a4b65a0d4449ec2d93967831c264c532123d828c849df62a367f7
+EBUILD boto-2.49.0-r2.ebuild 972 BLAKE2B 75b9deca3bb8c6ede255ffdb0cb2387290b5e9cdf7f1ae3a868ffe28b044a24925af5bae0c787cbb806a5943ec1d1a96d5f7fcdf134d53aa2c2e9208a09e61cf SHA512 62756c8ec6ef5b50ff31bd35ced6c7a5f4ad60aebfdfd3d59441ebdde9a1712951a9d5e9c224e0ea9d1de330aceebcac71f0e3862df4c1d6915e26160a5c0d65
EBUILD boto-2.49.0.ebuild 716 BLAKE2B e8ddc4cf764002fc0e9e86de50b5ea4a97d06b386525f7d54d9655ad2b32b7372c5ea74b7042004edb6e45e8ec56488da46e0ceed45f4f331f0f58669204dd40 SHA512 a939e1be7b3e0d6d57564d25161404c1c51efcde213606607cb5a7cf792ab12eb72cd25fa4113a01e908da8fd4b3e27eae5232570a6bbdb8d319056e88b3a24a
MISC metadata.xml 419 BLAKE2B c6c19e4ba3ecc5a36b535267b75cdf3afb7317e577e8f0899d43a334632633d771b5e5216517537616cc99c7766a852d2b4c5b132e174f8481d86649253e0897 SHA512 ee5587224538b14f67c30eda60c161e4c07c801c4b4edb24bcb0350e17c4d655c4d9a6907ebe5913d7689e1b6078ef25f47b4fe0a7c655cfa8d5ea775b4d0329
diff --git a/dev-python/boto/boto-2.49.0-r2.ebuild b/dev-python/boto/boto-2.49.0-r2.ebuild
index 4cb94d5afa65..0e774e24a221 100644
--- a/dev-python/boto/boto-2.49.0-r2.ebuild
+++ b/dev-python/boto/boto-2.49.0-r2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
DISTUTILS_USE_SETUPTOOLS=bdepend
inherit distutils-r1
@@ -12,23 +12,27 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="test"
-
-BDEPEND="
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-
-RESTRICT="!test? ( test )"
-
-# requires Amazon Web Services keys to pass some tests
-RESTRICT+=" test"
+KEYWORDS="amd64 arm arm64 ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
PATCHES=(
# taken from https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=909545
"${FILESDIR}/boto-try-to-add-SNI-support-v2.patch"
+ "${FILESDIR}"/${P}-py38.patch
)
+distutils_enable_tests nose
+
+src_prepare() {
+ # broken, not worth fixing
+ rm tests/unit/cloudfront/test_signed_urls.py || die
+ # fix tests
+ mkdir -p "${HOME}"/.ssh || die
+ : > "${HOME}"/.ssh/known_hosts || die
+
+ distutils-r1_src_prepare
+}
+
python_test() {
- "${PYTHON}" tests/test.py -v || die "Tests fail with ${EPYTHON}"
+ nosetests -v tests/unit ||
+ die "Tests fail with ${EPYTHON}"
}
diff --git a/dev-python/boto/files/boto-2.49.0-py38.patch b/dev-python/boto/files/boto-2.49.0-py38.patch
new file mode 100644
index 000000000000..0052c6e32e86
--- /dev/null
+++ b/dev-python/boto/files/boto-2.49.0-py38.patch
@@ -0,0 +1,54 @@
+diff --git a/boto/ecs/item.py b/boto/ecs/item.py
+index 79177a31..292b05af 100644
+--- a/boto/ecs/item.py
++++ b/boto/ecs/item.py
+@@ -21,7 +21,7 @@
+
+
+ import xml.sax
+-import cgi
++import html
+ from boto.compat import six, StringIO
+
+ class ResponseGroup(xml.sax.ContentHandler):
+@@ -67,7 +67,7 @@ class ResponseGroup(xml.sax.ContentHandler):
+ return None
+
+ def endElement(self, name, value, connection):
+- self._xml.write("%s</%s>" % (cgi.escape(value).replace("&amp;amp;", "&amp;"), name))
++ self._xml.write("%s</%s>" % (html.escape(value).replace("&amp;amp;", "&amp;"), name))
+ if len(self._nodepath) == 0:
+ return
+ obj = None
+diff --git a/tests/unit/utils/test_utils.py b/tests/unit/utils/test_utils.py
+index db15b56d..89d1a524 100644
+--- a/tests/unit/utils/test_utils.py
++++ b/tests/unit/utils/test_utils.py
+@@ -85,7 +85,7 @@ class TestPassword(unittest.TestCase):
+ def hmac_hashfunc(cls, msg):
+ if not isinstance(msg, bytes):
+ msg = msg.encode('utf-8')
+- return hmac.new(b'mysecretkey', msg)
++ return hmac.new(b'mysecretkey', msg, digestmod='MD5')
+
+ class HMACPassword(Password):
+ hashfunc = hmac_hashfunc
+@@ -95,15 +95,15 @@ class TestPassword(unittest.TestCase):
+ password.set('foo')
+
+ self.assertEquals(str(password),
+- hmac.new(b'mysecretkey', b'foo').hexdigest())
++ hmac.new(b'mysecretkey', b'foo', digestmod='MD5').hexdigest())
+
+ def test_constructor(self):
+- hmac_hashfunc = lambda msg: hmac.new(b'mysecretkey', msg)
++ hmac_hashfunc = lambda msg: hmac.new(b'mysecretkey', msg, digestmod='MD5')
+
+ password = Password(hashfunc=hmac_hashfunc)
+ password.set('foo')
+ self.assertEquals(password.str,
+- hmac.new(b'mysecretkey', b'foo').hexdigest())
++ hmac.new(b'mysecretkey', b'foo', digestmod='MD5').hexdigest())
+
+
+ class TestPythonizeName(unittest.TestCase):