summaryrefslogtreecommitdiff
path: root/dev-python/blosc/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-python/blosc/files
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-python/blosc/files')
-rw-r--r--dev-python/blosc/files/blosc-1.9.1-unbundle.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/blosc/files/blosc-1.9.1-unbundle.patch b/dev-python/blosc/files/blosc-1.9.1-unbundle.patch
new file mode 100644
index 000000000000..55af5f0c621a
--- /dev/null
+++ b/dev-python/blosc/files/blosc-1.9.1-unbundle.patch
@@ -0,0 +1,23 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 2711877..a4c949c 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -4,16 +4,9 @@ find_package(PythonExtensions REQUIRED)
+
+ # Todo: c-blosc provides a CMake package configuration file that we can build
+ # against if blosc is available on the system, etc.
+-# find_package(blosc)
+-# if(NOT blosc_FOUND)
+-set(BUILD_STATIC ON CACHE BOOL "Build a static version of the blosc library.")
+-set(BUILD_SHARED OFF CACHE BOOL "Build a shared library version of the blosc library.")
+-set(BUILD_TESTS OFF CACHE BOOL "Build test programs form the blosc compression library")
+-set(BUILD_BENCHMARKS OFF CACHE BOOL "Build benchmark programs form the blosc compression library")
+-set(CMAKE_POSITION_INDEPENDENT_CODE ON)
+-add_subdirectory(c-blosc)
++find_package(blosc)
+
+ add_library(blosc_extension MODULE blosc/blosc_extension.c)
+-target_link_libraries(blosc_extension blosc_static)
++target_link_libraries(blosc_extension blosc)
+ python_extension_module(blosc_extension)
+ install(TARGETS blosc_extension LIBRARY DESTINATION blosc)