summaryrefslogtreecommitdiff
path: root/dev-python/blake3-py-c/blake3-py-c-0.3.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-21 13:54:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-21 13:54:09 +0000
commit454de691f3543d47dc89cd0b137eaa9ea4640cd3 (patch)
tree90ec469ff7d2e1b1fac0b0f98f32d49dacb30278 /dev-python/blake3-py-c/blake3-py-c-0.3.3.ebuild
parente393c0503a79342594a61547dc43f80f8bcc086e (diff)
gentoo auto-resync : 21:12:2022 - 13:54:08
Diffstat (limited to 'dev-python/blake3-py-c/blake3-py-c-0.3.3.ebuild')
-rw-r--r--dev-python/blake3-py-c/blake3-py-c-0.3.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/blake3-py-c/blake3-py-c-0.3.3.ebuild b/dev-python/blake3-py-c/blake3-py-c-0.3.3.ebuild
new file mode 100644
index 000000000000..2f42063712f4
--- /dev/null
+++ b/dev-python/blake3-py-c/blake3-py-c-0.3.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P/-c}
+DESCRIPTION="Python bindings for the BLAKE3 cryptographic hash function"
+HOMEPAGE="https://github.com/oconnor663/blake3-py/"
+SRC_URI="
+ https://github.com/oconnor663/blake3-py/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}/c_impl
+
+LICENSE="|| ( CC0-1.0 Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ !dev-python/blake3-py[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd .. || die
+ epytest
+}