summaryrefslogtreecommitdiff
path: root/dev-python/blake3-py-c/blake3-py-c-0.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-15 23:13:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-15 23:13:45 +0100
commite87ef1b6ce856ae8859bdfce8028fb992f3e3763 (patch)
treed51e0c41adf3586e9a393881cee3ec0a9ed48977 /dev-python/blake3-py-c/blake3-py-c-0.3.1.ebuild
parent0c80ffd3caee224555f8b394b6b2c05b2752f440 (diff)
gentoo auto-resync : 15:09:2022 - 23:13:44
Diffstat (limited to 'dev-python/blake3-py-c/blake3-py-c-0.3.1.ebuild')
-rw-r--r--dev-python/blake3-py-c/blake3-py-c-0.3.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/blake3-py-c/blake3-py-c-0.3.1.ebuild b/dev-python/blake3-py-c/blake3-py-c-0.3.1.ebuild
new file mode 100644
index 000000000000..954d842bcbe7
--- /dev/null
+++ b/dev-python/blake3-py-c/blake3-py-c-0.3.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P/-c}
+DESCRIPTION="Python bindings for the BLAKE3 cryptographic hash function"
+HOMEPAGE="https://github.com/oconnor663/blake3-py/"
+SRC_URI="
+ https://github.com/oconnor663/blake3-py/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}/c_impl
+
+LICENSE="|| ( CC0-1.0 Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ !dev-python/blake3-py[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${P}-backports.patch
+)
+
+python_test() {
+ cd .. || die
+ epytest
+}