summaryrefslogtreecommitdiff
path: root/dev-python/black
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-09 22:34:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-09 22:34:14 +0100
commit3a77d78ca92715b58ddac074baa5b25c4baf9a9b (patch)
tree6dc147c4f02d9c37807f61c29d1fad916f967a94 /dev-python/black
parent785047acce64d1217286105397cc6fe433c34cb3 (diff)
gentoo auto-resync : 09:09:2023 - 22:34:14
Diffstat (limited to 'dev-python/black')
-rw-r--r--dev-python/black/Manifest2
-rw-r--r--dev-python/black/black-23.9.0.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/black/Manifest b/dev-python/black/Manifest
index a81533b014d3..fd573344b7a6 100644
--- a/dev-python/black/Manifest
+++ b/dev-python/black/Manifest
@@ -1,3 +1,5 @@
DIST black-23.7.0.tar.gz 586177 BLAKE2B 4bb50b6c7409a97aa277f1048c17101a1c91368b9269cf4c08d3052c036887d2ed6e5f1f2e044c14f41bf2d969d65183413c2a9810f12d96cbf09778c9b1310e SHA512 78d5e87bfef4dcaff007455e8c72dcd45f9374c09da6f4ba45ae7caa980005d1bc984c68fa44d4abf7969a376a4039546e7e8f537c3aa1331d213e13dcbe3941
+DIST black-23.9.0.tar.gz 588540 BLAKE2B f3c94acb1af6c4bf1ada948d4ea7b7cd243184b920fab7e741d9e5ee4a82e163e5570ca1451424ea379362ae1755907e4b5e63b517a4e420d6cbe9d69655a10f SHA512 4d1ae51353c7a0a4113796fcc10824228d5bd9a0f19474efc8c5e3a9b929433a586f058521fd1dae35301e9e33e6d231b0584f81514104ac5c787f8e55cb9fa8
EBUILD black-23.7.0.ebuild 1411 BLAKE2B a34b33a3cfbf25f22b27e60d26931c86fcb5c8121d02660e7f6fd96fc3fbb0e19199c99f00a51e7a1ad40bcafb0213a59f13104537db38301a128748c0a2c38c SHA512 440d1b59f0fe0f4e1901a6181e819940123886ff0e28db0670c88b72dd57771447fbe5dcb2e815b8bc057690571e0d740106f4dbf7bad08b5e2371ecb71311cb
+EBUILD black-23.9.0.ebuild 1419 BLAKE2B 159bb6253fead0e9868fa730d93cda3942b8bcbdeba595a4ed853a7a5b38de2c1118f7014637adf229fa94faec559d2620093a0d8d442f85771dc13b711947eb SHA512 7891509019d71dd6a88f6b07cbf7b706136f36b20695abb14dd0a75305adec58fffe5ab0f817553e587b61800da15f38146c3779149e23e06b66df4c3c94dd11
MISC metadata.xml 446 BLAKE2B 7d9bdbc4fdd62c1b4278a824a75dede64ccd3a4d865722a99edbd4e316342879eefa7b249c453668a5d33009e134e2feb4d1ac01976146c3e988f3724749d4a4 SHA512 0a3a912fc1d439a92452e48c9749705cd2307e645bb1274d22265656f6101574edda79cf04c03ae512818e7077e404f79fb1f70fd68d9c7cd3be3417f991700d
diff --git a/dev-python/black/black-23.9.0.ebuild b/dev-python/black/black-23.9.0.ebuild
new file mode 100644
index 000000000000..29726cd5e4ea
--- /dev/null
+++ b/dev-python/black/black-23.9.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 multiprocessing optfeature pypi
+
+DESCRIPTION="The uncompromising Python code formatter"
+HOMEPAGE="
+ https://black.readthedocs.io/en/stable/
+ https://github.com/psf/black/
+ https://pypi.org/project/black/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/click-8.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mypy_extensions-0.4.3[${PYTHON_USEDEP}]
+ >=dev-python/packaging-22.0[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/aiohttp-3.7.4[${PYTHON_USEDEP}]
+ dev-python/aiohttp-cors[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -n "$(makeopts_jobs)" --dist=worksteal
+}
+
+pkg_postinst() {
+ optfeature "blackd - HTTP API for black" \
+ "dev-python/aiohttp dev-python/aiohttp-cors"
+}