summaryrefslogtreecommitdiff
path: root/dev-python/bitstring/bitstring-4.2.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-27 00:07:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-27 00:07:23 +0100
commit3c1648a0749c1d66b300d857e6b417c1162890da (patch)
tree2b13f04c2c10d472e5bb7cc40fe6048bf8bc549d /dev-python/bitstring/bitstring-4.2.3.ebuild
parent994fe442814c4d169bb0f1ee9745604928006b39 (diff)
gentoo auto-resync : 27:05:2024 - 00:07:23
Diffstat (limited to 'dev-python/bitstring/bitstring-4.2.3.ebuild')
-rw-r--r--dev-python/bitstring/bitstring-4.2.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/bitstring/bitstring-4.2.3.ebuild b/dev-python/bitstring/bitstring-4.2.3.ebuild
new file mode 100644
index 000000000000..7aa2e31192ca
--- /dev/null
+++ b/dev-python/bitstring/bitstring-4.2.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pure Python module for creation and analysis of binary data"
+HOMEPAGE="
+ https://github.com/scott-griffiths/bitstring/
+ https://pypi.org/project/bitstring/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ <dev-python/bitarray-3[${PYTHON_USEDEP}]
+ >=dev-python/bitarray-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/gfloat-0.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ tests/test_benchmarks.py
+)