summaryrefslogtreecommitdiff
path: root/dev-python/bincopy/bincopy-20.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-30 17:49:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-30 17:49:05 +0000
commit28d8acbb30a9ebda81447e5e3f5210a438ba7d24 (patch)
tree6d6b6b0a1aca19e8118845870c9e6a25bad27963 /dev-python/bincopy/bincopy-20.0.0.ebuild
parent840a65e2af3f2cc7527e723a28f6e627a9592fb7 (diff)
gentoo auto-resync : 30:01:2024 - 17:49:05
Diffstat (limited to 'dev-python/bincopy/bincopy-20.0.0.ebuild')
-rw-r--r--dev-python/bincopy/bincopy-20.0.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/bincopy/bincopy-20.0.0.ebuild b/dev-python/bincopy/bincopy-20.0.0.ebuild
new file mode 100644
index 000000000000..1882e2a4f380
--- /dev/null
+++ b/dev-python/bincopy/bincopy-20.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Mangling of various file formats that conveys binary information"
+HOMEPAGE="
+ https://pypi.org/project/bincopy/
+ https://github.com/eerimoq/bincopy/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/argparse-addons-0.4.0[${PYTHON_USEDEP}]
+ dev-python/humanfriendly[${PYTHON_USEDEP}]
+ dev-python/pyelftools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest