summaryrefslogtreecommitdiff
path: root/dev-python/binaryornot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/binaryornot
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/binaryornot')
-rw-r--r--dev-python/binaryornot/Manifest3
-rw-r--r--dev-python/binaryornot/binaryornot-0.4.3.ebuild27
-rw-r--r--dev-python/binaryornot/metadata.xml11
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/binaryornot/Manifest b/dev-python/binaryornot/Manifest
new file mode 100644
index 000000000000..fd11d8bca586
--- /dev/null
+++ b/dev-python/binaryornot/Manifest
@@ -0,0 +1,3 @@
+DIST binaryornot-0.4.3.tar.gz 372299 BLAKE2B c4ae99b9ccb66da8925d74fad68b8df4713822acc74d852e2f584e5c157eb465bc6418b0e0085533479ba1ee937c3d2716dea66ce3bd517d49a490ab4615f694 SHA512 bdb918b921fc46d056572b84126dbdc6605ec98cf13aac84f6f64ce07d083839be40bf7a08185eaabfbe136a9bcf0c1acc8041a23a6bb2843e8e72981222ebaa
+EBUILD binaryornot-0.4.3.ebuild 677 BLAKE2B 19e3034852fd5cc3271a79523ae83ded3107602f3840a236f3b8ad7c056dd7589e7a4ef12892f5e6fd102614218ef4072fcdf04d4d0fe95e8a4b6833188fcb09 SHA512 89231391bc20744b9409098dc27e94d95d41c42c620241713a9b86b21869d9cef758e04557833376e9dc663b59f2bacd2ec52e8f3d63baa4df51831a79bae253
+MISC metadata.xml 324 BLAKE2B 85a0925b2255a6577beed4974beba21884b88df30bc1519f6ce16e856659589c6e6e38166540f59fb0043885ce786382d90b6830c6ed1bc0051a5d728a1f780b SHA512 f20343e29c9a1d2bb354ecb3c308d5b21985deed5368d27dc144c3a6f2e236f30f7516e27a56e55be48fda32bd59ae9af96ff3b90ecf641bf57dc5b61a4267c6
diff --git a/dev-python/binaryornot/binaryornot-0.4.3.ebuild b/dev-python/binaryornot/binaryornot-0.4.3.ebuild
new file mode 100644
index 000000000000..91e5e8d9d504
--- /dev/null
+++ b/dev-python/binaryornot/binaryornot-0.4.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Ultra-lightweight pure Python package to guess whether a file is binary or text"
+HOMEPAGE="https://github.com/audreyr/binaryornot"
+SRC_URI="https://github.com/audreyr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND=">=dev-python/chardet-3.0.2[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/hypothesis[${PYTHON_USEDEP}] )"
+
+DOCS=( README.rst HISTORY.rst CONTRIBUTING.rst )
+
+python_test() {
+ esetup.py test || die
+}
diff --git a/dev-python/binaryornot/metadata.xml b/dev-python/binaryornot/metadata.xml
new file mode 100644
index 000000000000..64d17e0e40e9
--- /dev/null
+++ b/dev-python/binaryornot/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">audreyr/binaryornot</remote-id>
+ </upstream>
+</pkgmetadata>